
WRPTOOL MANUEL D'UTILISATION FRANCAIS

Voici donc la traduction du logiciel wrptool dans sa version 2.1 publier en anglais le 11 
octobre 2003. La nouvelle version viendra donc un peu plus tard et j'espere que celle-ci vous
aidera deja.
Les createurs conseille vivement de lire ce manuel jusqu'au bout avant de vous servir de 
wrptool conseille que je me permet moi aussi de vous donner. 

Ce logiciel simplifie reelement la creation de map pour OFP mais demande un minimum 
de prise en main. Je vous pris d'avance de m'excuser pour les fautes d'orthographe 
que vous rencontrerez au cours de votre lecture en esperant qu'elle ne vous generons 
pas pour la comprehension du texte.

N'hesiter pas a envoyer un mail au cas ou vous ne comprendriez pas quelque chose, 
mais lisez bien tout avant (parfois il n'est pas necessaire de comprendre une 
remarque pour savoir comment sa fonctionne).

J'espere que cette traduction permettra au phobique de l'anglais de se mettre a creer de 
zolie map pour Operation FLashpoint.

Durant la lecture vous rencontrerez peut etre des mots non traduit, si c'est le cas faites le 
moi savoir.
Les mots ou groupes de mots entre guillemets son les textes existant dans le logiciel.
Si vous rencontrer des suites de lettres comme celle ci : "LMB" ou "RMB" cela signifie 
bouton gauche de la souris ou bouton droite de la souris. (left=gauche right=droite 
au cas ou vous seriez vraiment tres tres nul en anglais :P )

Aller sur ce: Bonne Lecture

Skaor
Re: Placed Image


Skaor
Placed Image




WrpTool – Utilitaire de creation d'ile pour OFP 
 
http://flashpoint.nekromantix.com/wrp.php
 
WrpTool Manual version 2.1  Oct 11th, 2003 
 
Ceci est un document sur WrpTool et la descriptions de ce qui lui est associé. Si vous 
ne trouver pas la solution a un probleme lier a WrpTool en lisant ce document, 
enregistrer vous sur notre site, aller sur le forum et poster un message 
pour demander de l'aide. Nous seront heureux d'aider toute personne ayant lu ce document et qui
a besoin d'aide ou qui veut rapporter un bug ou autres erreurs. 
 

 
 
 
 
Les dernieres mise a jours pour ce document peuvent etre trouver sur la page en ligne.
http://flashpoint.nekromantix.com/wrptool-manual.php
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INSTALLATION 
 
A noté que l'installation de WrpTool la premiere fois peut etre difficile pour beaucoup 
d'utilisateurs, beaucoup de mauvaises installations sont lier aux utilisateurs qui n'ont pas lu cette 
partie du manuel. Nous avons essayé de faire des instructions d'installation aussi clair que possible. 
 
Installer WrpTool est tres simple,premierement decompresser tout les fichier de WrpTool dans 
n'importe quel repertoire, il n'est pas necessaire de mettre les fichier a la racine du disque dur.
Personnelement j'utilise “d:\ofpstuff\wrptool\” comme repertoire de destination. 
 
 
WrpTool Repertoire de base 
 
Assurer vous d'avoir wrptool.exe, objects.ini, objects.xml, roaddef.xml et les deux fichiers 
DLL dans le repertoire de destination, vous avez egalement besoin du repertoire 3DPreview
avec les images bmp et icon_images.ini pour obtenir une previsualisation des
image afficher. 
 
Pour obtenir des textures et des objets visibles, vous devez decompresser les fichiers pbo utiliser dans
votre ile avec celle ci. Si un fichier de texture manque, la texture manquante sera remplacer
par une cellule rouge d'erreur, si un fichier p3d manque les graphisme par defaut seront 
affichés et les calculs d'altitude et de taille ne pourront etre terminer. 
 
 
Outil Un-pbo
 
pour decompresser les fichier pbo correctement vous devez utiliser un decripteur-pbo 
qui permet de dechiffrer le fichier. Nous vous suggerons PBO Decryptor v1.5 par Amalfi

Quand vous decompresser par exemple le fichier Data3D.pbo, il cré un repertoire “Data3D”
dans le repertoire ou celui ci se trouvait. C'est le repertoire correcte qu'il faut preserver
pour l'utilisation de WrpTool (Lire ci dessous). 
 
 
Configuration de WrpTool 
 
Lorsque vous avez mis tout les fichiers initial ensemble, la premier chose a faire dans WrpTool 
et d'aller dans  "Settings -> Change Settings" et configurer le chemin de votre
dossier de textures et d'objets. Normalment ca doit etre le meme, decompresser tout les pbo
necessaires dans le meme repertoire et configurer celui ci dans "Settings" comme 
dans notre image d'exemple. 
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Dans cette exemple la configuration a pour chemin e:\bis\ ou nous avons decompressé tout
les fichiers pbo du repertoire. Dans cette ecran de config. vous NE DEVEZ PAS lister les
addon individuel, NE PAS CONFIGURER par exemple e:\bis\Data3D\  
 
Vous avez compris, N'indiquez que le repertoire racine ou ce trouvent tout les 
autres dossiers. OK? 
 
 
Chemin/repertoire Addons
 
Maintenant, jettons un coup d'oeil sur le contenus du repertoire que nous avons
configurer dans la fenetre "settings" de wrptool, on devrait avoir quelque chose comme suivant. 
Par exemble notre repertoire serait e:\bis\Abel, e:\bis\Cain, e:\bis\Data, e:\bis\Data3D, 
e:\bis\Eden, e:\bis\O, e:\bis\sebnam_obj, etc avec ces fichier p3d et ces texture nous devrions
subvenir au besoin de notre ile. 
 
Maintenant jettons un coup d'oeil a cette exemple e:\bis\ et observons l'image d'exemple
si tout va bien il ne devrait pas y avoir de probleme, voyons voir… 
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Comme vous pouvez le voir, notre repertoire est e: \bis\ et tous les pbo de l'addon sont decompressés 
dans des dossiers, ce sont des sous-repertoire et ils apparaissent dans OFP comme des Addons. 
Vous ne devez pas  simplement decompresser les p3d ou les textures dans le meme repertoire, ils 
doivent être dans le repertoire d'addon leur correspondant, comme montré dans l'image ici. 


 
La plupart des erreurs liées a WrpTool sont dus a l'incomprehension de la decompression des PBO.
utilisez un decompresseur pbo correct, employez les sous-dossier comme creer par celui-ci 
et indiquer la racine du dossier a WrpTool. 
 
 
Windows 98, 98SE et Win ME 
 
WrpTool ne fonctionne malheureusement pas avec Win98, Win98SE ou WinMe. 
Nous devons vivre avec notre temps, et la plupart des gens ont aujourd'hui Win XP ou Win2k 
qui sont des versions bien meilleures. Il n'y a pas d'adaptation prévue pour ces ancienne 
version de Windows, et nous vous suggèront donc de mettre a jours votre systeme. 
WrpTool exigeant beaucoup de memoire systeme a cause des p3d et des textures (spécialement 


pour les grandes îles) il pourrait faire bugguer win98. 
 
 
Utilitaires supplementaires 
 
WrpTool contient PaNSee.exe (OFP Texture Browser v1.0) et 
ODOL_Explorer.exe (ODOL Explorer v1.0). Ceux-ci vous sont apportés par nos soin


comme petit plus au programme principal, nous ne fournissons pas la documentation 
mais voici une courte explication: utilisez le bouton "load texture" de PaNSee pour 
passez en revue les repertoires de vos textures, utiliser alors le curseur pour passer en revue
les textures de ce repertoire. ODOL Explorer, utiliser votre souris pour passer en revue les fichier p3d, 
utilisez SHIFT+LMB+Souris gauche/droite pour incliner la vue 3d, CTRL+LMB+Souris 
Avant/Arriere pour zoomer/dezoomer. Quelques textures et modèles p3d peuvent ne pas être 
correctement chargé, c'est normal. 
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OPERATIONS DE BASES
 
Dans le menu principal nous pouvons voir "FILE", "SETTINGS", "EDIT" et "VIEW". 
Voici leur description.
 
"FILE - > NEW" crée un nouveau fichier wrp. Celui ci demande une taille de cellules pour l'île.
Les tailles de cellules sont 256 par défaut (12.8km x 12.8km), 512 (25.6km x 25.6km) et 
1024 cellules (51.2km x de 51.2km). 
Vous pouvez mettre également 2048 (102km x 102km) mais nous avons pus observer des crash 
de la map ou de simple disparition de terrain et d'objet. 
 
"FILE -> LOAD WRP…" Charge un fichier wrp existant.
 
"FILE -> SAVE WRP…" enregistre le fichier wrp en cours. Nous vous conseillons de le faire souvent.
 
"File -> Import WRP Cells…" importer un fichier wrp. 
 
"File -> Export WRP Cells…" selectionnez une cellule et exporter la en fichier wrp. 
 
"File -> Import Wilbur…" importez un fichier de "wilbur"
 
"File -> Exit." Heu...pour quitter le logiciel au cas ou vous seriez vraiment si mauvais en anglais.
 
"Edit -> Align all obj. to ground…" placera tout les objets au meme niveau que le sol. 
 
"Edit -> Align selected obj. to ground…" placera l'objet selectionner au meme niveau que le sol. 
 
"Edit -> Replace Textures…" ouvre la boite de dialogue pour changer  les textures. 
 
"Edit -> Deselect All…" CTRL-D Deselectionne tout objet selectionner. 
 
"Settings -> Change Settings…" configurer le repertoire ou il y a les textures et les objets. 
 
"Settings -> Add Textures…" Permet d'ajouter des textures a celles deja existantes

 
"Settings -> Add Objects…" meme chose que pour les textures mais pour les objets. 
 
"View -> Object Browser…" Affiche la boite de dialogue permettant de visualiser
les objets contenus dans le dossier configurer oulister  dans le fichier objects.ini.
Le raccourcis clavier et CTRL+O ici indiquer STRG+O.
STRG et l'appelation de CTRL en allemand.
 
"View -> Texture Browser…" meme chose que pour les objets sauf que c'est pour
les textures.
 
"View -> Object Inspector…" CTRL-I affiche l'inspecteur d'objet vous permettant d'indiquer
ces coordonnées sa rotation ainsi que son type.
 
"View -> Object Placer…" CTRL-P permet d'ajouter un objet identique a celui selectionner dans 
la rangée ou dans la colonne a coter de celui ci.
 

 7



"View -> Object Tool…" CTRL-R. Permet de redimensionner un objet. 
 
"View -> Elevation Tool…" CTRL-E pemet de surelever le terrain ou au contraire
de l'abaisser.
 
"View -> Mini Map…" CTRL-M affiche la mini map de la carte en cours qui vous 
permet de vous deplacer par un simple clique dans la zone sur laquel vous desirez
travailler. 
 
"View -> 3D View…" Vous donne un apercus 3D de votre carte.
CTRL+LMB pour tourner autour de la carte LMB+SOURIS pour zoomer 
et RMB+SOURIS pour bouger dans la carte. 
 
Dans la partie inférieure de l'écran, vous pouvez voir une zone "GRID", ici vous pouvez 
selectionner le style d'affichage de votre carte. "GRID": "CELL" affiche des carreaux representant 
50m x 50m. Si votre zoom sur la carte n'est pas asser avancé vous ne pourez pas voir la grille,
il suffit alors de zoomer et celle ci se devoilera. 
"GRIS":"OFP" vous permet d'afficher une grille de reference (pour trouver une zone facilement). 
 
 

 
 
"Mouse Position" indique des informations detaillées sur l'endroit ou ce trouve le curseur
au moment present.  
"Cell: x / z". X represente le decompte de gauche a droite, 0 et la plus petites taille de
cellules. Vous souvenez vous de "Cell Sizes"? Ok laisser moi vous rappellez. une ile de 12km 
et entre 0 et 255 cellules, de 25km entre 0 et 511 cellules et 51km entre 0 et 1023 cellules. 
Z represente le decompte de bas en haut des cellules. Si vous avez "Cell: 0 / 0" 
vous etes en bas a gauche de la carte, "Cell: 1023 / 0" vous etes en bas a droite de la carte
et "Cell: 1023 / 1023" en haut a droite. 
Ensuite vous avez les valeurs X, Y et Z qui indique les coordonnées dans l'ile. X represente de 
gauche a droite, Y la hauteur et Z de bas en haut. si vous avez, X: 0 et Z: 0 vous etes en bas a
gauche et X: 51200.0, Z: 0 en bas a droite d'une carte de 51km etc... 
Les coordonées proviennent d'une taille de cellule de "* 50", voici les taille des plus grandes
coordonnées pour les iles: ile de 12km 12800.0, ile de 25km 25600.0 et ile de 51km (prise en
exemple ici) 51200.0. 
 

 
 
"Current Object" vous donne un apercus de l'objet situer sous le pointeur de la souris, 

 8



celui ci montre le nom du fichier p3d, sa direction (entre 0 et 359.9 degrés), sa taille en pourcentage, 
et sa position X,Y,Z. Si l'objet actuel et selectionner dans "object brush" un texte vous l'affiche. 

 

 
 
La fenetre "Object Brush" affiche l'objet actuel selectionner (avec la touche "HOME"), 
cet objet peut etre placer sous le curseur de la souris en appuyant sur "ALT+LMB" ou "INS". 
Si aucun objet n'est selectionner il n'y aura pas d'image. 
 
La derniere fenetre et une fenetre qui se charge au debut de wrp et vous affichant quelques  
info sur votre ile. Il y a; la signature (4WVR ou OPRW possible), taille en X et Z, 
quantitée de texture dans l'index, quantités de texture et d'objet 3D utiliser. 
Cette boite d'information affichera par la meme occasion certaines erreurs.
 
 

 
 
Utilisez votre molette de souris pour zoomer sur la carte. Le bouton droit de la 
souris (RMB) vous permet de vous deplacer sur la carte.
Le bouton gauche (LMB) et utiliser pour selectionner un objet, placer un objet, deplacer
un objet et tracer un cadre de selections autour des objets. 
 
En bas a gauche de l'ecran vous pouvez choisir d'afficher: les lignes de niveaux, les textures 
(bouton "terrain"), et les objets. "colored" permet d'avoir un apercus couleur du relief ou de tout 
laisser blanc, "Roads" affiche les routes placer avec l'outil "Road Tool" et "Real" qui permet l'affichage
reel des forme p3d. Il y a egalement le nom du fichier actuellement charger.
 
 

 
 
"Levels" sont des lignes qui vous permettent de mieux reperer les endroit ou il y a une 
elevation ainsi que la forme de celle ci. Vous pouvez aussi voir l'altitude par les couleurs
du terrain. Le bleu represente le niveau de la mer et le vert foncer represent 1m d'altitude. 
Plus l'altitude est elevée et plus la couleur ira vers le vert clair. 
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Lors de l'appuie sur "Textures (f7)", sur la barre superieur, le terrain se retrouve immediatement 
selectionner. La vue dezoomer au maximum vous donne un apercus de la couleur des textures, 
mais quand vous zoomer vous pouvez apercevoir les textures en detaillées. Si votre zoom et tres
rapprocher les textures n'apparetront que sous forme de grains. 
 
"Colored" est un fond blanc pouvant aider au placement de certein objets p3d qui peuvent 
avoir le meme fond que la map. 
 
Mode "Real": permet d'afficher les objets p3d dans leurs vraies forme en mode fils de fer.
Votre zoom doit etre asser pres pour afficher les formes p3d. Vous ne pourrez pas voir les
formes si votre zoom et trop eloigner. 
Vous voyez ainsi la forme qu'aura votre objet sous OFP meme si certain objet peuvent
etre asser laid, une fois les textures posées ca n'aura plus rien a voir. 
Cet apercus est tres utiles pour placer les objet dans le bon sens. 
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QUELS SONT LES DIFFERENTS OBJETS?
 
Les objets sont les fichiers P3D (models 3D) ce sont des arbres, des buissons, des roches, 
des maisons, des routes mais aussi des armes, des vehicules etc. Cependant, dans ce document, 
nous ne parlons que des objets statique. 
 
La pluparts des objets constituant l'ile sont, la vegetation (arbre, roche, foret etc...).
Mais on a aussi les objets "humain" (maison, route, barriere et bien d'autre).  

 

 
 
Les barrieres, routes et certains objet de foret sont connecter entre eux, posés individuellement
ils peuvent etre placer dans le mauvais sens ou bien meme ne pas fonctionner (route).
Cependant la plupart des objets peuvent etre placés individuellement celon vos désirs. 
 
Deja avec les ancienne version de wrptool on pouvait voir lors d'un zoom suffisement 
puissant la veritable forme des p3d. meme si ca parait emmeler (du a la vue "fil de fer" au
dessus) elle n'en reste pas moins efficace pour placer les objets dans le bon sens. 
 
Dans WrpTool le centre des objets p3d et indiquer par un marqueur jaune, 
Celui ci vous indique son centre d'equilibre ainsi que l'endroit ou vous devez
cliquer pour le deplacer. 
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EXPLORATEUR D'OBJETS 
 
Dans cette fenêtre vous pouvez passer en revue les objets disponibles dans votre fichier objects.ini, 
ceci n'a rien à faire de quels Addons et objets vous pouvez avoir dans votre dossier OFP. 
 

 
 
Quand vous cliquez droit sur le nom d'un objet, vous obtenez des options pour bloquer (lock) 
ou debloquer (unlock) l'objet, Bloquer ou debloquer tout les objets de cette catégorie. 
Quand vous avez un ou plusieurs (mais pas tous) objets bloquer dans une catégorie, 
vous obtenez le symbole de cadena ainsi q'un demi cadena devant le nom de la categorie (voir image)
 

 
 
Vous pouvez aussi bloquer la categorie entiere en cliquant sur le bouton droit 
de votre souris puis sur Lock/Unlock. Si vous bloquer une categorie un cadena
complet apparaitra devant celle ci. 
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Vous pouvez aussi bloquer l'objet par simple clique gauche a coter de son nom.
Dans ce cas un cadena apparaitra clairement a coter de lui.
les objets bloquer apparaissent avec un contour gris et la fenetre de previsualisation
aura un texte "Locked" pour vous indiquer son status verouiller.
 
Blocker un objet vous permet de ne pas pouvoir le supprimer, le bouger ou le tourner.
Ceci est tres pratique si vous desirez, par exemple, supprimer la roche de votre carte mais que
vous desirez laisser le reste de la vegetation intacte.
 

 
 
Si une croix apparait sur le p3d en face du fichier c'est que celui ci existe
dans le fichier objects.ini ou bien a ete charger sur le nouveau fichier wrp
mais n'a pas ete configurer dans votre bibliotheque d'objet (repertoire d'objet non
ajouté) 
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RECHERCHE D'OBJETS 
 
Uitilisez "Object Finder" pour placer un nouveau fichier p3d dans "object browser", utilisez
le alors normalement pour placer des objets. Le fichier p3d n'est pas ajouter dans object.ini
si vous ne le placer pas dans le repertoire de votre map. 
Si cela n'est pas fait l'objet sera perdu lors de la fermeture de wrptool. 
 

 
 
Si vous devez ajouter de nouveaux objets, utilisez "Object finder" pour les placer dans 
"Object browser", placez-les sur l'île puis ajoutez les dans objects.ini en utilisant notepad 
ou un éditeur de texte semblable. Dans le fichier ini vous pouvez indiquer la catégorie 
du ou des objets p3d ajoutés. 
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INSPECTEUR D'OBJET
 
C'est un outils simple d'edition d'objet. vous pouvez configurer la position exacte de
l'objet actuellement selectionné, ainsi que sa taille. "Fit to ground" et selectionner
par defaut et dvrait etre utiliser. Vous pouvez aussi changer l'objet par un autre par 
l'intermediaire de l' "Object Browser". 
 

 
 
Si plusieurs objets sont selectionner vous ne pourrez pas utiliser "object inspector".
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PLACER UN OBJET
 
Pour placer un nouvel objet P3D dans la carte il y a deux manieres de faire, par pression
sur le bouton de souris ou copier coller le ou les objets. premierement allez dans
"View -> Object Browser…" et cliquer sur un objet d'une categorie. 
Maintenant aller dans la vue de la carte wrp et placer votre curseur a l'endroit ou vous voulez
inserer l'objet, puis appuyez sur  "INSERT" ou "ALT" et Bouton Gauche de votre souris
(LMB) et ainsi l'objet sera placer.  
 
Si vous utilisez l'option “Random Dir”, l'objet sera placer dans n'importe quel direction
sur un l'angle de 360°. Si vous ne l'utilisez pas l'objet sera automatiquement orienter au
nord (0°). Si vous desirez ajouter un nouvel objet cliquer sur "Add New" dans "object browser".
Ceci affichera automatiquement la fenetre "Object Finder" 
 
 
Vous voyez la direction de l'objet sur son icone sur la map. Sa direction est 
indiquer par une fleche noir.
 
 

 
 
Si vous desirez editer la rotation de votre objet il vous suffit de selectionner l'objet
puis de mettre votre curseur au dessus de cet objet, maintenir la touche "SHIFT" gauche,
et le bouton gauche de votre souris, puis de bouger la souris autour de l'objet pour
changer la direction de la fleche noir. 
Lorsque l'option “Real” et selectionner, vous voyez les formes reel des objet
p3d. Ceux si doivent ressembler un peu comme a ce sur l'image. 
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Il est tres facile de placer ses p3d au bonne endroit avec cette vue.
Cela vous permet a coup sur de bien placer votre maison sans la positionner sur un arbre
etc...
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DEPLACER UN OBJET 
 
Si vous desirer changer la place d'un objet il vous suffit de le prendre avec la souris  
et de l'y deplacer. Mettez le pointeur de souris au dessus de l'objet a deplacer, appuyez
sur le bouton gauche de votre souris, deplacer l'objet dans la zone desirer et relacher le bouton
pour y deposer cet objet. 
 
Vous pouvez aussi utiliser le clavier, utiliser les fleches de celui ci pour deplacer l'objet selectionner, 
"SHIFT" + "Fleche" pour changer sa direction. Utilisez "CTRL" pour deplacer ou tourner plus vite.
 
Si vous avez accidentellement attraper un objet non desirer et que celui ci c'est deplacer
vous pouvez,si votre bouton gauche de souris et encore appuyer, presser "ESC" et l'objet
retournera a sa position initial. 
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OBJETS MULTIPLE 
 
Si vous desirez agire sur plusieurs objets a la fois, vous pouvez tracer un cadre autour
d'eux. Quand leurs contours seront rouge, cela signifira qu'ils sont selectionner.
or objects is selected. Maintenant vous pouvez cliquer gauche sur l'un des objet
et tout le groupe selectionner suivra, maintenez "SHIFT" et le bouton gauche, faite une 
rotation autour du groupe et celui ci suivra. Vous pouvez utilisez le clavier (voir section precedante).
 
 

 
 
La rotation effectuer sur un objet multiple revient a faire tourner un objet simple. 
Le groupe complet et donc considerer comme un seul objet.

 
Si vous avez plusieurs objets selectionnés (indiquer par un contour rouge) et que vous 
appuyez sur "DEL" alors tout le groupe sera supprimer. Ceci est tres pratique si vous desirez 
remplacer une foret par une ville par exemple. 
Faites attention tout de meme a ne pas supprimer quelque chose de non desirer. 
Si vous desirez deselectionner un groupe, appuyez sur "CTRL+D" ou tracer un cadre dans
une zone vide. 
 
 
Copier et coller
 
Cela fonctionne comme pour toute application standard, c'est a dire "CTRL+C" sur l'objet 
a copier (apres l'avoir selectionner), puis "CTRL+V" a l'endroit ou on veux coller l'objet.  
C'est aussi simple que ca. 
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Le dernier objet coller sera toujours automatiquement selectionner. Pour le deselectionner
appuyez sur "CTRL+D" ou dessiner un cadre dans une zone vide. 
 
Si vous desirez bloquer une categorie d'objet pour eviter tout mouvement par erreur
mettez votre curseur au dessus de l'objet puis appuyez sur "L", un texte rouge indiquant
"Locked" dans la fenetre de previsualisation de l'objet indiquera que l'objet et bloquer.  
 
Lorsque un ou plusieurs objets sont selectionner une boite rouge apparait en bas a droite
permetant de centrer sur la selection. 
 

 
 
Lorsque plusieurs objet sont selectionner en meme temps toute action s'execute sur 
l'ensemble de la selection. 

 
 
Aligner les objets au sol 
 
Si vous voyez dans OFP une maison enterrer ou qui vol utiliser "Edit -> Align all obj. to the ground"
ou "Edit -> align selected obj. to the ground" ceci peut arriver qu'un objet
ne soit pas aligner avec le sol et si c'etait le cas utiliser cette commande

 
vous devez avoir vos fichier p3d ranger dans le bon repertoire pour que cela 
fonctionne. Si il ne sont pas detecter par wprtool il ne seront pas aligner.
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PLACEUR D'OBJET 
 
"Object placer" et fondamentale pour placer vos barriere car il fait un travail merveilleux
pour placer des objet droit et parfaitement aligner. Il prend les valeurs X et Y de l'objet
selectionner, (veillez a n'avoir qu'un objet selectionner lorsque vous utilisez le mode
"Object placer") et place le meme p3d a coter de celui ci selon l'axe X ou Y.
 

 
 
En premier vous selectionner un objet sur la map, puis vous aller dans le menu 
"View -> Object Placer" ou vous appuyez sur "CTRL+P". Puis vous choisissez
"Row Align" (a droite de l'objet selectionner) ou "Col Align" (au dessus de l'objet selectionner). 
Maintenant cliquer sur "Copy & Place", un nouvel objet et créé juste a droite (ou au dessus)
de l'objet selectionner, si c'est une barriere elle se retrouve connecter, si c'est une maison elles
se retrouvent mur a mur. 
 
 
noter que vous pouvez creer aussi bien a gauche et en bas. Pour ce faire appuyez
sur le bouton "<->" qui permet de basculer en valeur negative et qui fera exactement 
le meme travail qu'en positif mais a l'inverse. 
 
Le bouton "Lock" sert a bloquer les valeurs X et Z. Exemple: les objet d'une foret sont censé etre
a une taille de 50x50m (une cellule), mais que le pack que vous avez telecharger contient des objet
de 54x54m quand vous aller placer l'objet il y aura un ecart entre eux.
Mais si vous mettez 50 50 dans X et Z-Dist , et que vous cliquer sur "lock" pour bloquer ces valeurs
vos objet seront correctement alignés. 
 
 
 

 21



OUTIL OBJETS
 
"Objects Tool" et un outil de redimensionnement, il est tres utile pour changer la taille
des objets. la taille normal et considerer a 100% mais vous pouvez augmenter ou
baisser cette valeur, bien que nous vous deconseillons de depasser 290%
ou vous risqueriez d'avoir des probleme au niveau de l'affichage et de pouvoir 
marcher sur certains objet (arbre). 
 

 
 
Vous pouvez faire apparaitre "Objects Tool"avec CTRL-R ou par "View -> Objects Tool…" 
Une fois ouvert, vous avez la possibiliter de selectionner l'objet a redimensionner. 
Vous devez d'abord blocker les categories d'objet que vous ne voulez pas redimensionner
(Barriere, Maison, route par example).  
 
La boite "Random..." contient les info les plus importante: la boite de gauche (dans notre image)
indique 50%; c'est la plus petites taille possible, et la boite de droite indique 150% qui est
la plus grande echelle a employer. Lorsque vous cliquez sur "Rescale", 
tout les objets selectionner sont alors redimensionner avec la valeur specifiée.
 
 
Le bouton "Direction" vous permet de changer aleatoirement la direction
des objets selectionnés. Cliquez autant de fois que vous desirez changer celle
ci. 
 
Si vous avez un objets selectionner non desirer vous pouvez le selectionner
puis appuyer sur "Remove from selection" pour le retirer, ou encore appuyez sur "CTRL+D"
ou bien tracer un cadre dans une zone vide de la map. 
 
Voici un arbre redimensionner a plusieurs echelles; Les soldats a coter n'ont pas ete
redimensionner ainsi vous pouvez voir ce que ca donne. 
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et dans wrptool… 
 

 
 
Comme vous pouvez voir, a gauche l'abre a 50%, puis a 100%, 150% et enfin
250%. 
 
A noter qu'il ne faut pas faire les arbre trop grands si vous ne voulez pas
que certains vehicule aeriens ne pouvant voler a plus d'une certaine altitude
se heurte a celui ci. De plus a plus de 290% il y a des erreus d'affichage.
Cela reste quand meme possible bien qu deconseiller.
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REMPLACER DES OBJETS 
 
"Replace Objects" permet de remplacer un objet1 par un objet2. Vous ne pouvez
remplacer un objet par deux ou trois, mais vous pouvez remplacer un objet
contre un seul autre. Nous parlons des differents type d'objets ici, l'effet desirer pourra
etre executer sur un objet selectionner ou trouver dans la map wrp. 
 
Ceci vous sera surment utile si vous desirez remplacer par exemple votre foret
par de nouveaux arbres ou tout autre sorte d'objet.
Ainsi il n'y a alors besoin d'aucun travail manuel.

 
Remplacer un objet 
 
Selectionner l'objet a remplacer, en passant par "object browser" ou directement
sur la map en placant le cuseur au dessus de l'objet et en pressant la touche "HOME".  
Maintenant selectionnez "Edit -> Replace Objects…". Dans la fenetre "old objects" cliquez sur
"Objects -> from Obj Browser" pour ajouter l'objet choisi (par "object browser" ou pression de
la touche "HOME" au dessus de l'objet sur la map), selectionner l'objet de remplacement, et
appuyez sur "New Objects -> from Obj Browser" .  
 

 
 
Dans cette image nous avons selectionner l'objet "sebkrovi4.p3d" pour le remplacer avec
l'objet "sebelekrovi2.p3d". Si nous avions selectionner plusieurs objets et appuyez sur 
"Replace Selected", l'operation n'aurait eus lieu que sur les objets selectionnés. Si nous avions
appuyez sur "All button", tout les anciens objets aurait ete changer. 
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ROUTES 
 
Les routes sont utiliser par l'IA pour aller d'un endroit a un autre lorsqu'elle utilise
un vehicule. Aussi bien l'IA que les jjoueurs humain peuvent l'utiliser, ce qui permet
a ceux ci de rouler plus vite que sur l'herbe ou tout autre support qui n'est pas une route.
 
L'icone de route et afficher, comme tout autre icone, dans sa vrai taille ainsi que sa vrai
forme p3d.  
 
WrpTool a un outil "Road Tool" permettant de placer les routes convenablement les unes aux autres
et devient tres rapide d'utilisation apres familiarisation avec cet outil.
 
 
Configurer les routes
 
Pour acceder au menu de definition des routes, commencez par charger ou creer une
nouvelle map. Cliquez ensuite sur "Settings -> Road Definer…" maintenant vous devez voir 
apparaitre la fenetre si dessous.
 

 
 
"Road Classes" correspond au pieces principale de la chaussée, "Connectors" correspond
aux routes servant pour les carrefours mais ne sont pas encore supporter. Maintenant que vous
etes pres a ajouter votre route, assurez vous de bien avoir selectionner le bon type de route, cliquez 
sur le bouton "New" (pas "<-New"), et on vous demandera le non de la nouvelle classe de route. 
Ce nom portera celui que vous desirez mais dans notre exemple ce sera celui de SEB NAM: 
"Pack’s SEB Trail Path". 
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Cliquez "OK" pour continuer ou "Abbrechen" pour "annuler". Vous avez donc créé
votre premier type de route dans WrpTool et vous etes pres a ajouter different objets p3d
representant une route dans votre classe de route. Appuyez sur "<- New" et vous
devriez obtenir cette fenetre. 
 

 
 
Ceci et la fenetre permettant d'ajouter les route p3d individuelle. La boite de dialogue "P3d"
indique le chemin ou se trouve votre objet route; le bouton "…" vous permet de rechercher
cette objet. "Alias" est le nom qui apparaitra sur la route elle meme.  
"Length", "Angle" et "Radius" son les valeurs de l'objet p3d utiliser pour la route.
"Terminator" est cocher si la route et un objet p3d terminateur.
"Terminator" peut etre selectionner par l'utilisateur. Celui ci
se coche automatiquement si la variable "Konec" et presente dans cet objet. 
 
Maintenant cliquez sur "…" , pour chercher l'objet dans la fenetre de recherche.
Dans "Object Finder" rechercher donc le fichier p3d representant la route qui vous 
interesse et que vous desirez ajouter, dans notre exemple il s'agit de "SEB 
NAM trail paths". 
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Peut importe l'ordre dans lequel vous les ajouter, vous pourrez les arranger plus tard
dans le menu "Road Tool". Par contre vous ne pouvez pas en selectionner plusieurs a la fois, 
vous devez les choisir un par un. Nous avons selectionner "sebtrailpath6konec.p3d" et cliquer sur OK, 
nous avons alors obtenus cette fenetre. 
 

 
 
On peut apercevoir le nom et le chemins dans lequels se trouve le fichier dans la boite "P3d".
Dans "Alias" se trouve le nom original du fichier mais rien ne vous empeche de le personaliser.
Dans "Length" on peut voir 6.25 ce qui indique que la route fait environ 6.25 metres de long.

 
Maintenant il faut faire ca avec tout les morceaux de routes qui vous interessent, y compris
les courbes; La difference et que vous obtiendrez deux nom dans la fenetre "define road".
Voici l'exemple de notre courbe. 
 

 27



 
 
Maintenant, la longueur est a zero mais l'angle est a 10 et "radius" (rayon) et 
a 25.
 
Maintenant tout les fichiers p3d ont ete ajoutés, vous pouvez voir les courbes, mais elles
sont toutes lister deux fois avec marquer "_R" ou "_L" a la fin, sela indique si la courbe
tourne a droite ou a gauche. 
 
Maintenant vous pouvez si vous le desirez ranger les noms de routes, cliquez sur
la route que vous desirez deplacer dans la liste puis cliquer ensuite sur "Move up" ou "Move down" 
jusqu'a le mettre a la place desirer. Si vous rearanger les icones de cette facon, les courbes
resteront toujours par couple.
Ce que je veux dire c'est que si vous desirez par exemple mettre toutes les courbes droites
ensembles et de meme pour les courbes gauche ce ne sera pas possible puisque chaque couple
de courbe utilise le meme fichier p3d.
 
La liste finale pour "SEB Trail Path" ressemblera donc a peut pres a ceci:
 
 

 
 
Bien, maintenant que vous avez terminer avec la liste cliquez sur "OK" et celle ci sera
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enregistrer dans wrptool dans le fichier "RoadDef.xml". Vous ne comprendrez pas grand chose 
si vous editer ce fichier avec un editeur de texte. Utiliser l'outil "road definition" pour editer
votre liste. 
 
 
Placer les routes
 
Pour placer une route ouvrez "Object Browser" et selectionnez 
data3d\cesta6konec.p3d piece de termination. Ensuite placer l'objet normalement
sur la map, Sa direction se trouvera au nord 0.0 degrés.
Si vous deselectionner le mode "Real" vous verrez la fleche pointer vers la dirction de la route.
Maintenant selectionner l'objet "Konec" en dessinant un rectangle autour de l'objet
(les bord doivent alors devenir rouge). 
 

 
 
Ici les bords sont jaune car la souris se trouve au dessus de l'objet.
 
 
Selectionner "View -> Road Tool…". Vous obtiendrez alors le menu "Road Tool".         
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Maintenant cliquez sur "New", et indiquer le nom a donner a la route. Ceci et juste pour votre aide;
il n'y a pas besoin d'indiquer le nom du fichier p3d, juste un nom inventer comme dans l'image
en dessous. 
 

 
 
Ce nom vous aideras juste a savoir a quel route c'est. Maintenant que vous avez cliquez
"OK" , vous voyez toutes les informations necessaire dans la fenetre "Road Tool". 
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Vous voyez apparaitre le nom que vous venez de creer en haut, ceci montre que c'est
UNE ROUTE. Vous pouvez avoir plusieurs chemins identique sur votre carte; 
Celui ci en est l'un d'eux. Disons que nous l'avons appeller “Dirtroad in north” et nous lui
avons donner une identification unique ainsi qu'un role unique a jouer dans la carte. 
 
OK maintenant que nous somme pres a utiliser "Road Tool" pour placer les p3d dans la carte
, commencons. 
 
Vous avez selectionnez le morceau "Konec", "Road Tool" ouvert… Maintenant utilisez le bouton
droit de votre souris (RMB) pour cliquer sur le nom (dans la fenetre "Parts") du morceau a placer. 
Le nouvel objet route sera placer a 0.0 degrés au nord de la route "Konec"… 
au nord (càd. vers le haut). cliquez avec RMB sur "cesta12" et voila, vous avez a nouveau placé
12 m de route en plus vers le nord de la piece Konec! Maintenant cliquez juste
sur une piece de la route comme "cesta10 25_R" et "_L" etc. 
 
Une ligne jaune est tracée entre tout les morceaux du meme nom, ils sont toujours
affichées quand le bouton "Roads" et selectionner dans l'interface utilisateur.
Vous pouvez changer cette couleur en cliaquant dans l'angle superieur de la fenetre 
"Road tool". 
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Si vous le desirez vous pouvez appuyer sur "Append"… celui ci realise la meme operation pour
placer les objet route, mais RMB et beaucoup plus rapide quand il faut placer beaucoup de piece. 
"Delete last" effacera la derniere route placée; vous pouvez effacer toute les parties de la route
que vous avez poser jusqu'a revenir a l'objet Konec. 
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Apres quelques clique nous obtenons deja une route interressante. Remarquez que WrpTool 
centre automatiquement la vue 2d sur le nouveau morceau de route creer, ceci permet 
de faire un zoom large sur la map tout en gardants la route comme centre de notre vue
et ainsi vous ne vous retrouvez pas perdus a chercher votre route.

 
Lorsque vous avez terminer il ne vous reste plus qu'a placer un route de fin Konec pour terminer
le chemin. La prochaine fois que vous desirez modifier une route sur votre carte, creer un nouveau
nom de route et placer un konec pour commencer a placer de nouvelles sections de route. 
 
Les routes de votre carte seront sauver dans le fichier "<nom de l'ile>.rrp" , si vous venez a 
editer le fichier wrp avec un autre editeur,ne bouger pas les routes sinon vous risquez
de ne plus pouvoir charger le fichier RRP dans WrpTool. 
 
 
Reconstruire une route
 
Si vous avezrealiser un changement sur vos routes, vous pourriez avoir besoin du dispositif de
reconstruction des routes. "Rebuild road" marche convenablement avec quelques petits problemes
sur les routes placer avec "Road Tool", la reconstruction ne peut fixer des bugs sur des routes 
prefabriqués et placés manuelement. 
 
Supposons qu'il manque des morceaux a votre route, ou bien simplement un morceau mal
placer ou encore un morceau superposé sur un autre. Cela pourrait donner comme dans
l'image qui suit.
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La route n'est pas au mieu
ainsi, vous ne pensez pas? 
 
Mais vous pouvez voir que 
cette route a ete placer a 
l'aide de "Road Tool" puisque  
la ligne jaune existe. 
Vous pouvez en ce moment
ajouter manuelement des 
morceaux de routes entre les
deux Konecs.  
 
Pour ajouter un morceau, 
selectionner le bouton "Insert
After", Choisissez le morceau
auquel vous desirez ajouter
une autre portion de route. 
Puis cliquer RMB sur la 
piece que vous desirez ajouter
apres celle selectionner.
Celles ci se retrouvent alors
connectées. 

Reparer cette route ne peut 
pas etre plus simple. Appuyez
sur "Rebuild" en haut de la
fenetre "Road tool"
et votre route est reconstruite avec tout les objets placés entre l'objet Konec de 
depart et celui de fin.
 

 34



 
 
C'etait facile n'est pas? Veuillez noter ceci si vous ajouter/effacer beaucoup de route
et que vous les reconstruisez souvent, elles risquent de se decalés vers la fin du
konec. Faites bien attention lorsque vous utiliser "Insert After" et que vous reconstruisez 
toute votre route. 
 
 
Effacer route 
 
Si vous avez besoin, vous pouvez effacer une route entiere, pour cela il vous suffit
de selectionner dans la boite de selection la route a supprimer et d'appuyer sur
"Delete Road". "Road Tool" vous demandera de confirmer, si vous repondez "yes"
la route sera supprimer du wrp. 
 
 
Placement automatique de route 
 
Cette option n'est pas encore disponible mais nous projettons de realiser
un outil permettant de selectionner l'endroit de depart de la route, la fin de 
celle ci ainsi que ses points de passage et son type puis par la pression
d'un bouton de tracer celle ci automatiquement.
Pas d'inquietude ca arrive!
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FORETS 
 
Utiliser un objet "FOREST" peut reelement ameliorer le developpement de votre carte ainsi que
sa jouabilitée, l'objet "FOREST" et en realiter un groupe d'arbre creer en tant que simple
objet. Les forets sont plus facile a placer ainsi que manuelement et elle prenne en plus de ca
moins de place et de temps de chargement sur l'ordinateur. Les forets sont differentes
des autres objets dans le sens ou elle recouvre toute une zone definie. 
Il y a trois type de foret differentes. En employant les forets vous permettez ainsi de diminuer
les ralentissements dus aux objets placer individuellement.
"BIS" utilise une methode simple pour creer une foret dans une petites section. 
"Resistance" ajoute certaines choses que nous verrons plus tard. (CWC) Il y a trois type
principaux d'objet de foret, deux moitiées de carrée se refletant, et un coin supplementaire
permettant de comblé les trous. Voici une image d'une foret simple utilisant 
"BIS \data3d forests". 
 

 
 
Vous pouvez voir trois triangles de couleurs differentes representant chacun des objets
differents. Le vert est souvent appelé T1, le bleu T2 et le rouge n'a pas d'appelation
particuliere. comme ceci 

 
data3d\les ctverec pruchozi_t1.p3d = vert
data3d\les ctverec pruchozi_t2.p3d = bleu 
data3d\les trojuhelnik pruchozi.p3d = rouge 

 
T1 et T2 sont tournés face a face à 0 degrés, nord. Le triangle rouge et orienté en fonction
de l'endroit ou il est placé sur les bord de la foret. Pour des raisons que nous expliquerons
plus tard, il est fortement recommander de placer les forets de sorte que tout les objets de celle
ci soit placer vers leur direction d'origine (en position normal) a moins que vous ayez prevus 
autrement. Si vous centrer votre foret et laisser T1 et T2 pointés vers le nord
ainsi que l'autre traiangle a 0, 90, 180 ou 270 degrés, vous vous eviterez bien du fil
a retordre.
 
"Resistance" ajoute plusieurs amelioration pour les forets. D'abord, le "O\ 
forests" qui rend les forets plus agreable a regarder, meme si cela demande de meilleur
performance materiel. Un nouveau type de feuillage et d'arbre. De plus une section "square"
et maintenant valable, mais uniquement pour "O\ forests". Utiliser une section "square"
permet une meilleur vitesse de developpement et un meilleur resultat sur les map dans
WrpTool. 
 

 36



"Resistance" a cependant un probleme. Vous ne pouvez pas placer directement  "O\ forests" 
comme avec les objets "Data3d\ forests". Vous devez ajouter un classe speciale de
'ReplaceObjects()' dans "addon\config.cpp\addon.defaultworld.cfgworlds" qui remplace
la foret (X) par la foret (X) ou tout autre foret. Si vous ne realiser pas ceci vous aurez
des problemes d'affichage de votre foret dans resistance (flottement par exemple).

 
Voici un echantillon: 
class CfgWorlds 
{ 
class DefaultWorld {}; 
class Intro : DefaultWorld {}; 
class testcali: Intro 
{ 
... 
// ====== end ILS ====== 
class ReplaceObjects 
{ 
// ====== Comments by shinRaiden – BEGIN ====== 
//====================================== 
// this syntax removes a bogus p3d... 
//====================================== 
class Forest1Border 
{ 
replace="O\Tree\les_nw_ctver_mlaz.p3d"; 
with[]= {}; 
}; 
//====================================== 
// a little weird, replacing ourself... 
//====================================== 
class Forest1Triangle 
{ 
replace="O\Tree\les_nw_trojuhelnik.p3d"; 
with[]={"O\Tree\les_nw_trojuhelnik.p3d"}; 
}; 
//=================================== 
// -- Individually placed, these stair-step: 
// O\Tree\les_nw_ctver_pruhozi_T1.p3d 
// O\Tree\les_nw_ctver_pruhozi_T2.p3d 
//=================================== 
class Forest1Square 
{ 
replace="O\Tree\les_nw_ctver_pruhozi.p3d"; 
with[]= 
{"O\Tree\les_nw_ctver_pruhozi_T1.p3d","O\Tree\les_nw_ctver_pruhozi_T2.p3d"}; 
center="true"; 
}; 
//====================================== 
// this syntax removes a bogus p3d... 
//====================================== 
class Forest2Border 
{ 
replace="O\Tree\les_nw_jehl_mlaz.p3d"; 
with[]={}; 
}; 
//====================================== 
// a little weird, replacing ourself... 
//====================================== 
class Forest2Triangle 
{ 
replace="O\Tree\les_nw_jehl_trojuhelnik.p3d"; 
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with[]={"O\Tree\les_nw_jehl_trojuhelnik.p3d"}; 
}; 
//=================================== 
// -- Individually placed, these stair-step: 
// O\Tree\les_nw_jehl_T1.p3d 
// O\Tree\les_nw_jehl_T2.p3d 
//=================================== 
class Forest2Square 
{ 
replace="O\Tree\les_nw_jehl_ctver_pruhozi.p3d"; 
with[]= 
{"O\Tree\les_nw_jehl_T1.p3d","O\Tree\les_nw_jehl_T2.p3d"}; 
center="true"; 
}; 
//=================================== 
// --- EXPERIMENTAL – Works. --- 
//=================================== 
class Forest2T1 
{ 
replace="O\Tree\les_nw_jehl_T1.p3d"; 
with[]={"O\Tree\les_nw_jehl_T1.p3d"}; 
}; 
class Forest2T2 
{ 
replace="O\Tree\les_nw_jehl_T2.p3d"; 
with[]={"O\Tree\les_nw_jehl_T2.p3d"}; 
}; 
// ============================= 
// This p3d is only 2d planes, and you can not walk inside. 
// -- O\Tree\les_nw_jehl_ctver.p3d 
// I made up the className "Forest2Plane" 
// ============================= 
class Forest2plane 
{ 
replace="O\Tree\les_nw_jehl_ctver.p3d"; 
with[]={}; 
}; 
// ====== Comments by shinRaiden – END ====== 
}; 
... 
}; 
}; 
 
En utilisant une section "square", Vous placerez une section de foretsen une fois plutot que
d'avoir a mettre une section T1 et T2. Pour qu'ils se fondent correctement a votre map
vous devez utiliser le code "ReplaceObjects()".

 
 
Autre objets de foret
 
Il existe "SEB" et "BAS" qui ont creer des objets forets, ceux ci sont: "SEB NAM 
Pack 2 jungle objects" avec des objets de jungle tiré de "BAS Tonal", les triangles ici
couvrent la totalitée des cellules de 50m. Mais ils sont aujourd'hui beaucoup editer.
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La routine de placement automatique de foret sous wrptool fonctionne sous un standard
de troix style d'objets de foret qui fonctionne. Si tout va bien nous pouvons obtenir un code auto
de placement pour les objets simple de "SEB" et "BAS". 
Actuellement WrpTool n'a pas de placeur automatique de foret; le systeme et basé sur
l'ancienne version de wrptool. Nous projettons d'ajouter un systeme totalement automatisé
pour placer les forets dans une version future de wrptool.  
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PONTS 
 
Placer un (en tuilisant le pont o\misc\[?] noe.wrp) peu vous donner mal a la tete.
Ofp rique d'avoir quelques probleme de limitation au niveau du placement. 
Dans la notice on dira qu'OFP ne laissera pas "voler" les ponts.
 
 
Voici quelques directives:  
  
Si l'altitude du terrain au niveau de votre pilier est = (N) la hauteur maximum de votre
pont est N+20.78, arrondi a N+21. Example:  
  
-20- ==7== -20-  
###\__0__/### 
 
L'altitude des deux coter du terrain est de 20. la riviere est a 0. Tous les ponts 
devrait etre a une altitude de 7. Si vous rampez a l'une des extremitées du pont, 
vous noterez une differnece de niveau entre le pont et le terrain. C'est normal, 
ceci permet d'assortir le pont avec une route.  
  
Pour un croisement de fleuve, voici la limitation maximum.  
  
_33_ ==20== _33_  
###\___0___/### 
 
SZi vos remblai sont < (riverbottom+13),Vous devez mettre votre riviere a une valeur
negative pour egaliser a 13 du fond de la jante. En regle general: 
Les ponts sont placer a (remblai - 13) 
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ICON IMAGES 3DPREVIEW 
 
Le repertoire 3Dpreview/ contient une resolution de 128 x 128 et 256 couleurs pour les
images bitmap de tout les Objet P3D disponible dans le fichier icon_images.ini. Ce repertoire est
utiliser pour afficher un apercus des objets 3d contenus dans le "object browser" ou lorsque
la souris est dur un objet de la map. Le fomat Ini est le suivant. 
 

data3d\krovi.p3d=data3d_krovi.bmp 
 
Ceci lirait l'objet krovi et montrerait data3d_krovi.bmp dans la fenetre de previsualisation.
Le format est tres simple <p3d>=<bmp> et vous pouvez indiquer vos propres
p3d et bmp si vous ajouter de nouveaux objets dans la carte, ou si vous pensez
que l'image original est de trop mauvaise qualitée. 
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OBJECTS.INI 
 
Ce fichier controle quels objets p3dsont afficher dans "object browser" 
et dans quels categories ils sont placer. Disons que nous avons ce qui suit: 
 

data3d\fortress1.p3d=houses 
 

Ceci placerait fortress1.p3d dans la categorie “Houses” dans "object browser" 
Ceci permet a l'utilisateur de changer d'objet 3d tout en sachant a quoi il correspond
et donc d'en essayer des centaines avant de trouver le bon. Le format est donc
celui ci: <p3d>=<category> et vous puvez specifier votre propre categorie
pour les objet p3d, mais les categories sont creer dans le fichier objects.xml 
(Lire plus bas). 
 
En vous promenant sur la map, si vous voyer des objets p3d avec un point d'interrogation
cela signifie que wrptool n'a pas identifier l'objet placer a cette endroit.

 

 
 
Cela veut dire que WrpTool ne supporte pas l'objet actuel ou que l'objet p3d est
manquant dans le fichier objects.ini. Disons que vous aver creer un p3d sur votre
et c'est la premiere fois que vous utilisez WrpTool, puis vous voyez ce p3d inconnus
dans "Object Browser" et de categorie inconnue. Wrptool vous previens au demarrage
quels p3d il manque. 
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XML 
 
Le fichier Objects.xml contient la config du fichier XML pour les icones p3d afficher sur
la carte. Vous devez utilisez notepad pour editer les fichiers .xml ou un editeur XML.
WrpTool contient le fichier objects.xml que vous puvez utilisez, mais vous ne devriez pas avoir
besoin de l'editer. Si vous ajoutez un models p3d dans une nouvelle categorie (houses, trees, etc)
Vous pourriez avoir besoin de les ajouter dans ce fichier. 
 
 
 
Niveau de la configuration de detail (LOD) 
 
Si vous desirez ajuster le “niveau de detail” de l'objet afficher sur la carte 
vous devez changer cette partie du fichier xml  
 

<SimpleLOD>200</SimpleLOD> 
<DetailLOD>100</DetailLOD> 

<Version>2</Version> 
<RealLOD>12</RealLOD> 

<DetailTextureLOD>50</DetailTextureLOD> 
 
Ceci contiendre le niveau de zoom; SimpleLOD est la quantitée que vous obtenez les pixels gris 
des objets affichés. Il est conseiller d'avoir un nombre elevé, ainsi vous verrez toujours (meme
si la vue est haute) un apercus du placement de vos objets sur l'ile. Cependant suivant la 
configuration de votre pc il faut adapter sur un chiffre plus faible lorsque la machine est
plus lente. Utilisez des valeurs comme: 50, 100, 200, 400, 500 etc selon votre PC. 
 

 SimpleLOD 
 
DetailLOD est quand les icones detaillés des objets est afficher sur la carte. 
Ce sont les icones indiqués dans le fichier de config. XML; il ne represente pas les formes 
reel des objet 3d.  
 

 DetailLOD 
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RealLOD est quand on a les formes reel des objets p3d, suivant votre configuration
d'ordinateur il faudra l'adapter car cet affichage demande un bonne puissance
de votre pc. C'est tres cetainement la meilleur vu car elle vous permet de voir les vraies formes
des objet et ainsi de les placer precisement. On voit dans cette vue a quoi
ressemble les objets vu du dessus.
 

 RealLOD 
 
DetailTextureLOD est un apercus “couleur moyenne” quand on passe en mode d'affichage
des textures. Si votre zoom est trop faible vous ne verrez surment rien, mais si vous zoomer 
proche du terrain DetailTextureLOD vous permet alors de voir des textures reeles.
Quand des textures sont affichées, vous les voyez a la hauteur de votre zoom.

 

 DetailTextureLOD 
 
 
 
Ajouter une nouvelle categorie
 
Pour ajouter une nouvelle categorie dans "object browser", vous devez configurer le fichier
objects.xml. Copier coller la categorie "Misc" est changer la comme il vous
convient. La config actuel du XML pour cet example "Misc" est celle ci:
 
 <Class> 
  <Classname>misc</Classname> 
  <Shape> 
   <Rectangle> 
    <Point> 
     <X>-50</X> 
     <Z>-50</Z> 
    </Point> 
    <Point> 
     <X>50</X> 
     <Z>50</Z> 
    </Point> 
   </Rectangle> 
  </Shape> 
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  <Color> 
   <Red>128</Red> 
   <Green>0</Green> 
   <Blue>0</Blue> 
  </Color> 
 </Class> 
 
Toutes les categories commencent par <Class>, et finissent par </Class> et entre
les actions qui se produisent. <Classname> est le nom de la categorie qui apparait
dans "object browser". <Shape> est le genre d'icone a dessiner dans wrptool; il y a
Ellipse, Rectangle et Pie. Il comporte les taille des valeurs <X> et <Z>.
<Color> c'est simplement les valeurs RGB de la couleur de l'icone.
 
 
 
Objets Manquant dans Wrp Load 
 
Si des objets manque dans le repertoire p3d que vous charger pour votre map wrp
un message vous indiquequels sont les objets p3d manquants. 
names. Par contre si des objets manquent dans le fichier objects.ini, cette erreur apparait.
 
 

 
 
Ceci indique que les objet p3d afficher sur la carte ne seront peut etre pas correctement
aligner sur le terrain et qu'ils pourraient flottés ou etre enterrés sous le sol.
Vous ne pourrez donc pas voir l'affichage des objets dans la vue 2d et 3d.

 
Si vous cliquez "yes", vous verrez une liste des objets p3d charger par le fichier
wrp mais qui manquent en realiter dans la configuration du repertoire d'objets p3d. 
Voici comment cela apparait:  
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Il est cependant facile de fixer le probleme en decompressant les fichiers dans le repertoire
d'objets p3d ou simplement en copiant le "output log" 
dans votre "objects.ini" et ajouter a la fin “=misc” en indiquant la categorie que vous desirez
pour ces objets. 
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ELEVATIONS 
 
L'Elevation correspond a la hauteur du terrain. 
Dans vous pouvez mettre des valeurs negatives qui correspondent au niveau sous la mer et
des valeurs positives qui sont les montagnes. Le niveau de la mer est a 0 metre.
Les valeurs conseiller a utiliser dans une carte sont –50 à 1000m. 
La valeur maximum dans WrpTool est 1474 metres. Attention car lorsque vous mettez
une valeurs extreme l'affichage du terrain sous OFP peut bugger, et ainsi vous aller voir 
la mer traverser les montagnes ou encore d'autre probleme. Si vous avez entrez des
valeurs moyenne, il ne devraait y avoir aucun probleme. 
 

 
 
 
Niveau de la mer et marée
 
La mer est interessantes puisque OFP gere les marées sur une hauteur de 5m. Cela signifie
que le niveau de l'eau augment et baisse durant la journée et selon la saison, Alors n'oublier
pas que si vous avez un objet important a coter de l'eau il ne se retrouve pas immerger lors 
de la marée haute. La marée haute est a midi (1200hrs), encore selon les saisons. Prenez 
donc en consideration la forme de votre ile. Si vous ne voulez pas qu'un objet touche l'eau quel que 
soit le moment placer le au moins a 6m d'altitude. 
 
 
 
Map / Editeur de mission: Lag 
 
La rugositée du terrain affectera les performances dans la vue de carte (M) et l'editeur de mission 
dans OFP, si l'elevation est tres differentes, vous aurez alors un temps de chargement
assez long. 
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Durant le jeu il n'y aura pas de ralentissement mais lorsque vous chargerez l'editeur de mission 
ou la carte (avec la touche M), vous obtiendrez tres certainement un "lag".
Vous devrez testez differentes elevations du terrain pour trouver le bon equilibre. 
 
 
 Il est possible que ca lag meme avec une ile en 12,8Km x 12,8km si l'elevation est trop forte.Ev
 Evitez de depasser un terrain de plus 25 et 51km pour limiter les gros lags juste dut a l'importation
 de la map qui cause un ralentissement du CPU.
 
Vous pouvez evitez ce genre de lag en utilisant "Wilbur Blur tool" sur le terrain que vous avez 
importer.Il a ete remarquer que les grandes elevations ne sont pas changer mais que les irregularités
des faibles elevations sur la carte amenent a laguer et son donc corrigés. 
Utilisez l'outil "Smooth/Blur" !  
 
Ou ce trouve le point d'elevation? 
 
Le point d'elevation de chaque cellule se trouve etre le coin inferieur gauche. Ceci
peut sembler confus au depart mais voici une illustration de la facon dont  
travaille le systeme d'elevation. 
 

 
 
Le point d'elevation appartient ici a la cellule 2/2, et entraine avec lui l'elevation
des trois autres cellules pour que le terrain soit au mieux. 
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MODIFIER L'ELEVATION 
 
Choisissez d'abord l'outil "elevation" situer en haut du panneau ou appuyez
sur F6.
 

 
 
Maintenant vous pouvez editez a l'aide de la souris les cellules que vous desirez. 
La grille de cellules est automatiquement selectionner lorsque vous choisissez le mode elevation
pour vous aidez a trouver les point d'elevation sur la map. 
 
Maintenant vous voyez les reseaux de cellules sur le terrain. Les cellules qui permettent d'editer 
l'elevation sont indiquer toujours en bas a gauche, ce sont les points d'edition. Utilisez votre souris
pour selectionner un coin vous pouvez alors modifier son elevation. Dans l'image suivante nous  
montrons comment nous avons choisis notre point d'elevation, pour par exemple creer une 
riviere par exemple. 
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Lorsque la cellules a editer et selectionner, aller dans "View -> Elevation Tool…" ou appuyez sur 
CTRL-E pour ouvrir la boite d'edition "Elevations". Vous pouvez maintenant utiliser le mode 
"Select Mode" ou "Interactive mode", utilisez d'abord "Select Mode". Dans le mode "Select 
Mode" vous pouvez changez des valeurs relatives et absolue. Nous voulons editez l'elevation pour
 creer une riviere par 5 metres. Utiliser par defaut 5 dans la boite d'edition puis utilisez les fleches 
pour augmenter ou baisser l'elevation. Vous pouvez utilisez "Absolute Change" pour entrer une valeur
et l'appliquer a toute la selection en appuyant sur "set". Ceci est asser pratique pour laisser
par exemple une certaine disposition a une ville ou autre. 

 
Lorsque nous maintenons appuyez pendant un certain temps la fleche du bas, nous obtenons une 
 elevation basse pour les cellules choisis. 
  

 
 
Dans cette image vous pouvez voir que nous avons suffisemment abaisser le terrain pour faire
emmerger l'eau.  
 
Pour utiliser le mode interactif cliquez sur "Interactive mode". Votre souris ce change alors en cercle.
Placez votre pointeur a l'endroit ou vous desirez modifier. Quand vous appuyez sur le bouton gauche 
de la souris, le terrain augmente, appuyer sur Shift-Gauche et le bouton gauche de la souris, le 
terrain baisse. Utilisez "Rel. Change" pour parametrer la valeur qui sera appliquer a l'augmentation 
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ou l'abaissement du terrain. Faites attention car avec ce mode on obtient rapidement des montagnes 
Russe. 
 

 
 
Vous pouvez selectionnez plusieurs cellule en tracant un cadre a l'aide de la souris, ou en utilisant 
CTRL + LMB  pour selectionner individuellement les cellules. Dans l'image suivante nous avons 
selectionner plusieurs cellules dans une zone definie, on pourrait ainsi aplanir et mettre une base par 
example. 
 

 
 
Dans cette image nous avons soulevez plusieurs cellules dans leur largeur et hauteur, ainsi nous  
obtenons l'endroit ideale pour construire une base de depart ou encore une ville, une foret. 
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TEXTURES 
 
Les textures sont ce qui donne une apperence au terrain. Les textures d'OFP s'adaptent au cellules; 
Les textures peuvent avoir une resolution de 128x128, 256x256 ou comme dans Nogova 512x512. 
Vous pouvez aussi utiliser 1024x1024. Le textures sont limitées a 512 par iles; vous ne pouvez en 
avoir plus. 

 
Pour commencer l'edition de texture vous devez appuyer sur le bouton "Texture" de la barre 
superieur, quand vous cliquez sur "Texture" la grille de cellules est automatiquement selectionner 
puisque une texture correspond a une cellule, ce qui en soit et plus pratique pour placer ses
textures.  
 

 
 
Ouvrir le navigateur de texture en appuyant sur CTRL-T ou "View -> Texture Browser". Ce 
navigateur vous montre les textures actuellement charger dans le repertoire addon.
Ceci represente la fenetre ou vous selectionner la texture a inclure dans le terrain.
Si vous desirez ajouter une nouvelle texture, cliquez sur le bouton "Add New" pour afficher   
l'outil de recherche de texture. 
 

 
 
 
 
Ajouter des textures
 
Si vous desirez ajouter des textures dans le "texture browser" ou bien que vous commencer une 
toute nouvelle ile, vous devez utiliser le "Texture Finder" pour les ajouter. Pour demarrer le  
"Texture Finder" selectionnez "Settings -> Add Textures…" ou appuyez sur "Add New" le 
"texture browser" et vous verrez apparaitre la fenetre "Texture Finder". 
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Ici vous pouvez parcourir les repertoires ou vous avez decompresser les textures avec 
"PBO Decryptor v1.5" ou un programme similaire. 
Vous verrez un apercus de l'image en parcourant leur nom. Lorsque vous avez trouver
la texture qui vous interresse cliquer sur "Add to Texture Browser". 
Vous pouvez utilisez "Shift-LMB" pour selectionner plusieurs textures immediatemment. 
 
Les textures selectionner sont pretes a etre utiliser dans le "Texture Browser", mais si vous ne 
les ajoutés pas dans votre ile, elle seront retirer lors de la femeture de "WrpTool". Une bonne  
technique pour stocker vos textures dans votre ile est de les ajouter en bas de l'ocean, ainsi
elles ne sont pas visible par les utilisateur d'OFP, mais vous pouvez les voir sous l'eau dans  
"WrpTool" lors de la selection du bouton "Terrain".  
 
Lorsque vous ajouter une texture a votre ile faites attention a utiliser celle contenue dans OFP et 
n'oublier pas que vous avez la limite de 512 textures. Je m'explique: 
Si vous ajouter par example la texture "SEB NAM" et "Afghanistan", tout les utilisateurs de votre 
ile doivent avoir ces deux Addon installer pour pouvoir lire les textures contenue dans le fichier
pbo. Ne mettez pas ces textures dans votre package. Si vous desirez utiliser ces textures
mettez les dans votre map puis precisez dans un fichier "readme" qu'il faut a l'utilisateur ces Addons. 
RESPECTER LES AUTEURS DES MAPS MERCI !

 
Assurez vous d'avoir decompresser les textures (data.pbo, sebnam_obj.pbo etc) dans le repertoire
d'OFP "Addons" et dans le repertoire temporaire, pour etre sur que tout ce passe bien utiliser l'
utilitaire "pbo decrypter" car avec un autre vous n'etes pas sur que tout les fichier pbo est ete extrait 
correctement. 
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Erreur dans mes textures
 
Si vous faites une erreur dans le nom du sous-repertoire, et que la texture n'est pas trouver  
dans le jeu "OFP", vous ne verrez pas de textures et OFP finira certainement par planter. 
Donc decompresser dans le bon repertoire vos fichier textures. 
 

L'image suivante montre ce que vous voyez lorsqu'une texture vient a manquer. 
 

 
 
Les cellules sont afficher en rouge si une texture vient a manquer. Vous devez alors verifier 
vos parametres et vous assurer que vos textures on correctement ete decompresser. 
 
 
Placer les textures
 
Pour editer des textures, selectionnez une texture dans le "texture browser", pointez votre souris 
dans la cellules ou vous desirez ajouter la textures et appuyer sur la touche "INSERT", la texture 
est alors placer. Vous pouvez aussi prendre une texture du terrain en placant la souris sur la texture 
desirer et appuyer sur "HOME" (comme pour les Objets). 
 
Si vous maintenez "INSERT" (ou ALT-LMB) et bouger la souris, vous peindrez avec la texture choisie. 
currently selected texture. Si vous desirez peindre sur une zone plus large votre texture, vous pouvez 
selectionner les cellules a peindre choisissez votre texture et cliquer sur "SHIFT-LMB"  quelque part
dans la zone selectionner (cellules rouge), la texture est alors placer. 
Effectuer un zoom arriere si vous desirez selectionner une zone plus grande et maintenez la touche  
"CTRL" appuyer lors de la nouvelle selection pour ajouter celle ci a celle deja existante. 
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Remplacer une texture 
 
Si vous desirez remplacer une texture existante il y a une fonction creer pour ca.
C'est: "Edit -> Replace Textures…". Dans cette fenetre vous donner le nom de la texture a remplacer 
et le nom de la texture qui doit la remplacer. 
 

 
 
Ces texture proviennent du "texture browser", mais vous pouvez aussi les appellées manuellement 
ten saisissant le nom de la texture dans la boite de dialogue. utiliser "replace all", pour remplacer 
toute les textures du premier nom par celle du deuxieme. Si vous selectionner des cellules (dans le  
mode "texture") et que vous utilisez "replace selected Cells" les cellules changer seront uniquement 
celle selectionner. 
 
 

 
 
Ce travail de texture provient de "Malden airbase". 
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Lorsque vous realisez un zoom arriere extreme, les textures apparaissent dans des couleurs 
grossiere pour vous donner une idée de la texture posée. Quand vous approcher avec le zoom 
les couleurs sont plus reel puis finalement laissent place aux vraies textures, par contre 
si vous zoomez trop vous verrez les pixels de textures, ce qui est parfaitement normal. 
Celea depend du niveau du "detailedtexturelod".  
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VUE-3D 

Dans le menu "View" selectionner 3D View... Une fenetre s'ouvre alors avec les reliefs
en 3D. La vue 3D est afficher au niveau de zoom de la vue 2D. Vous devez dezoomer
au maximum pour voir la carte s'afficher en entiere.

 

 
 
Utilisez la touche CTRL et LMB pour zoomer sur la vue-3D vers l'avant ou l'arriere. 
Quand vous appuyez sur LMB et que vous deplacer votre souris la vue bouge vers 
la gauche ou la droite, vers le haut et le bas.
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Vous pouvez vous deplacer autour de la vue en utilisant la souris. Si vous voulez zoomer
appuyer sur CTRL + LMB et bouger la souris vers l'avant pour zoomer et vers l'arriere pour 
dezoomer. 
 
Pour tourner la map appuyer juste sur LMB seulement et bouger la souris. 

 
Pour ce dplacer autour de la map, appuyer sur RMB+bouger la souris. Gauche, Droite, avant 
arriere. 
 
Pour remettre la vue 3D a zero appuyer seulement sur R. 
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Lorsque le mode reel est selectionner, vous pouvez aussi bien voir les objets p3d dans la
vue 2D que dans la vue 3D a partir du moment que le zoom est asser avancer sur la carte.
Toute action commise dans ce mode en vue 2D se repercute sur la vue 3D en temps reel 
(deplacement d'un batiment, selection d'un objet etc...)
Dans notre exemple les maisons sont rouge et la selection d'un objet et montrer en rouge.
La couleur des objet est entrée dans le fichier object.xml et vous devriez les modifier comme
il vous convient pour mieux vous reperez sur la vue 3D. N'oublier pas qu'avec la vue 3D vous
pouvez voir plus precisement l'emplacement des batiments. 
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IMPORTER & EXPORTER  DES PARTIES D'UN WRP 
 
 
Pourquoi exporter une partie de votre ile? 

Imaginons que vous travaillez a plusieurs sur une meme ile, que quelqu'un s'occupe des
routes, et un autre de placer les villes, il devient alors plus pratique d'envoyer un bout d'ile
a l'autre pour que chacun avance tranquillement et que l'avancement de la map soit plus
rapide. 

Une fois que tout le monde a fini sont travaille il ne reste plus qu'a fusionner les deux partie
de l'ile et hop... Voila une jolie ile tout belle toute finie (enfin bon c'est pratique! ) 

 
 
Exporter 
 
Ici nous expliquons comment exporter et importer un morceau d'ile, vous aller voir c'est tres
simple. Aller dans "File ->export WRP Cells..." c'est alors qu'une nouvelle fenetre s'ouvre. 
 

 
  
Maintenant vous devriez voir la fenetre d'exportation de WRPTOOL. 
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Choisissez alors la region de cellules a exporter dans le fichier .wrp plus petit. 
Noter que le fichier wrp plus petit et compatible OFP si vous reduisez la taille au 
maximum a 32x32, 64x64 ... 
 
Vous pouvez selectionner les cellules manuellement en tracant un cadre autour des 
cellules a exporter. Utiliser LMB, tracer le cadre et relacher LMB. Les coordonnées sont 
alors indiquer dans les boites de dialogue.

 
Vous pouvez aussi entrer les coordonnées directement dans les boites de dialogue en indiquant
le debut de la selection et la fin sur les axes X et Z.  

Quand vous cliquer sur exporter wrptool demande sous quel nom vous desirez sauver le .wrp
faites alors attention a ne pas effacer votre map de base ou tout autre element.

 
 
Importer 
 

Une fois que vous avez recus un morceau de carte vous voudrez certainement la compiler avec
votre morceau de map. En premier lieux realiser des copie de sauvegarde de chacun des morceau 
de la carte existante pour etre sur de ne pas avoir de perte, imaginer que vous perdiez tout vos
travail (plusieurs heures bien entendus et comme si moi je perdait la traduction de ce foutus manuel)
que penserait les membres de l'equipe qui créent la map avec vous? (perso si c'est moi tu est mort)
 
Utiliser "File -> Import WRP Cells…" pour importer la parcelle de map. 
 Vous verrez alors la fenetre suivante apparaitre. 
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Ici vous decidez le morceau a importer ainsi que si vous le desirez le terrain, les objets 
et les elevations. 
 
"Destination start cell" correspond a ou commence la premiere cellule en bas a gauche, de la 
il se deplace vers le haut droit des cellules et importe tout ce qui est selectionner a la place des autres
cellules.  
 
Si vous selectionner "import only a part", vous devez specifier les gammes dans votre fichier  
d'export que vous voulez importer. 
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COMMENT CREER LE TERRAIN 

 Lorsque vous creer un terrain initial vous avez peu de choix. Vous pouvez utiliser
un utilitaire externe pour creer le terrain ou encore wrptool directement mais
c'est un processus lent qui necessite l'utilisation de l'editeur d'elevation. 
  
 
Utilitaires
 
Vous pouvez utiliser des utilitaire de creation de terrain automatique pour "peindre" 
vos terrains. Les principaux generateur de terrain sont TerraGen et  GeoFrac 2000. 
L'utilitaire pour mettre en forme ces iles s'appelle Wilbur. 
 
TerraGen crée des iles tres convenable pour OFP et supportent la possibiliter  
d'integrer de l'eau autour de la terre. GeoFrac 2000 n'a malheureusement pas cette
option et vous obligera a faire les modification vous meme, sauf si vous supportez 
les grosses montagnes pour delimiter les zones de fin de OFP.

 
 
GeoFrac 2000 
 
GeoFrac permet de faire des terrain tres propre pour OFP mais ne crée que les blocs 
continental sans eau autour. Selectionner pour commencer "Generators ->Synthesized".  
Puis "Preset samples -> The Rockies". Lorsque vous avez creer un terrain qui vous convient
aller dans "Terrain Filters -> Erode". Ainsi vous creez l'erosion du terrain.
 
 
Pour sauver votre terrain utiliser "File -> Export -> TerraGen ter", Utilisez cette config:
"Vertical Scale Factor: 1000" et "Base Height: 200" ce qui devrait creer l'ile a une taille convenable 
pour OFP. Essayer d'autre valeur si vous le desirer. "Base height" represente la hauteur de l'ocean.  
"Vertical scale" represente la valeur a laquelle vous pouvez augmenter le terrain. 
 
 
TerraGen 
 
TerraGen est asser difficile et il faut bien comprendre son principe pour realiser une bonne ile … ☺ 
 
 
Fichier TER ? 
 
Vous avez dut obtenir un fichier .TER aussi bien avec GeoFrac que TerraGen, alors, que faire 
avec? Wilbur permet de lire ces fichier. Utiliser Wilbur pour charger les terrains sauver avec 
GeoFrac ou TerraGen. 
 
 
Wilbur 
 
Wilbur est tres simple d'utilisation, selectionner "New", dans "Surface Size" vous puvez mettre
256x256 pour une ile de 12.8km, 512x512 pour 25.6km et enfin 1024x1024 pour 51.2km.
"Surface Edges" peut etre laisser par defaut. Nous n'allons pas entrer dans les details 
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http://www.geofrac2000.com/
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pour le moment, car tout est expliquer a la fin du manuel, mais sacher que lorsque 
votre ile est pretes il suffit de l'exporter dans le format lisible par WrpTool.  
 
 
Sauvegarder 
 
Selectionnez "File -> Save As…" et choisissez "Lon/Lat Text Mesh" dans les types de sauvegarde  
ecrivez alors le nom que vous desirez. Dans la boite de dialogue "export" cliquez sur "Set to Pixel" et 
editer "Decimal Places" à zero (0), et cliquez sur "OK" et le terrain sera sauvegarder. 
Editer la valeur "Z" pour baisser ou elever l'elevation general du terrain. 
 
Vous etes maintenant pret a l'importer dans "WrpTool". 
Faites "File -> New" pour creer un nouveau terrain, configurer la taille comme la carte exporter
par Wilbur car avec une taille differente la map ne s'affichera pas convenablement dans WrpTool.
Ensuite choisissez "File -> Import Wilbur…". Le terrain creer dans Wilbur devrait maintenant  
apparaitre dans WrpTool. 
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BINARISE 
 
Que signifie Binariser? Je ne sais pas vraiment ce qu'il fait de si bien pour OFP. 
Binariser (Binarize) convertit les models MLOD en fichier plus compacte appeller ODOL. 
"Binarized p3ds" ne peut etre charger dans O2 puisque O2 ne lit pas le format ODOL.

 
"Binarize" permet donc de compresser les fichier wrp. 
Pour exemple notre ile "nam25" dans un format 4WVR pese 51mb, et lorsqu'on lance
"binarize", la taille baisse à 21mb, ce qui permet de reduire la taille pour le telechargement 
et je pense que cela permet aussi a OFP de charger plus vite. 
 
 
4WVR en OPRW 
 
Pour changer votre ile du format 4WVR au format OPRW vous devez binariser. 
WrpTool sauvegarde toujours au format 4WVR format et si vous n'etes pas sure du format actuel  
de votre ile il suffit de regarder dans WrpTool la boite de dialogue du haut et verifier l'extension
du fichier ouvert. Voici les description.  
 
[ImportWrpFile] Signature: 4WVR 
[ImportWrpFile] Signature: OPRW, Version 2 
[ImportWrpFile] Signature: OPRW, Version 3 
 
Le format standard de sauvegarde de WrpTool est 4WVR, les iles Malden, Kolgujev et Everon sont 
a la version 2 du format OPRW. Nogova et toutes les iles binariser sont en version 3. Donc lorsque 
vos iles seront binariser elles seront dans la version 3 du format OPRW. 
 
Quand vous charger une ile provenant de WrpEdit elle est en OPRW v2 et Wrptool la chargera
correectement, mais lorsque vous sauvegarderez, elle sera alors en format 4WVR. Il faudra alors
faire attention car l'ID des objets change. Si vous avez une mission ou vous avez defini l'ID
d'un objet comme un pond ou une maison alors la mission ne fonctionnera plus comme avant.
Vous devrez redefinir l'ID de ces objets pour que ca refonctionne correctement. 
Il est donc tres fortement recommander de terminer la creation de l'ile avant de commencer
à y creer des missions. 
 
  
 
Comment Binariser vos fichier WRP 
 
Installer "Binarize v1.0" (oui utilisez la v1.0!), copier tout les objets p3d et les textures
utiliser dans votre ile dans le repertoire de "binarize" et dans un dossier portant le nom 
auquel les pbo renvois. "Binarize" vous indiquera des erreurs si un fichier utiliser vient a
manquer! Il est tres important qu'il ne manque aucun fichier utiliser par la map.
Si tout est bien configurer il ne devrait y avoir aucune erreur.

 

Desoler mais nous ne develloperont pas l'utilisation de "Binarize" car ceci est un manuel
dedier a Wrptool. 
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TAILLES DE L'ILE 
 
La taille par defaut de l'ile dans OFP est de 256x256, le terrain fait alors 12.8x12.8km.
Vous pouvez utiliser des tailles differentes comme 32X32, 64X64, 256X256 etc...
Par contre vous ne pouvez creer une ile en longueur uniquement (comme 64X128 ou autre).
 
 
 
Iles large 
 
La taille maximal gerer par OFP est 1024x1024 ce qui nous fait donc une ile de 51.2x51.2km, 
Si vous essayer 2048x2048 dans OFP, vous aurez alors une erreur de memoir meme si vous  
mettez que peu d'objet sur la carte. Le terrain lui meme est alors trop gros a gerer pour OFP. 

 

 Petites iles
 
L'ile la plus petite que vous pouvez creer sous OFP est de 2x2 ce qui est asser amusant.
Bien sure cette ile n'aurait aucun interet meme pour les fanatique de quake 3 mais bon
wrptool permet cette possibilitée. 
 
 
Vibration ou tremblement
 
Lorsque vous vous trouvez sur une ile de tres grosse envergure 51km tout particulierement
il se peut que vous aiyez des "secousse". Je m"explique, vous vous trouvez dans l'helico et alors
la cabine se decompose legerement, ou encore vous etes a pied et alors votre personnage tremble.
Ceci peut etre asser genant alors reflechisser avant de creer de tres tres grandes iles.  
 
 
Vegetation dans la map
 
Quand vous etes dans l'editeur de mission de OFP la vegetation est indiquer par des symbole
noir representant arbre, broussailles ou encore rocher... Lorsque votre ile est grandes l'affichage
de la vegetation peut etre tres gros. Voici un exemple de Montignac dans une ile de 51km. 
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Comme vous pouvez voir les arbres et buissons empietent sur les maisons car ils ont garder 
le taille d'affichage original. Dans une il de 25km l'affichage reste encore acceptable mais apres 
ca devient plus dure. La taille peut etre ajuster en editant le fichier "resource.bin". Cependant
si vous realiser cette modification il faudra alors ajouter votre ile dans le repertoire "MOD" du jeu 
et cela n'est pas recommander si vous realiser juste une ile mais peut devenir interessant si votre
ile fait partie d'un gros Mod/addon. 
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CONFIGURATION DE L'ILE  
 
Pour que votre ile OFP soit bien configurer nous avons besoin d'un petit addon pbo. 
Dans notre exemple nous utilisons “nam_25” comme nom d'addon, remplacer ce nom 
par celui que vous desirez. 
 
 
Repertoire de l'addon 
 
Creer un repertoire "nam_25/" directory folder. Placez y le fichier ".paa" (_nam_25.paa) 
qui donne l'apercus de l'ile dans l'editeur de mission OFP (Nous expliquerons plus tard
comment creer ce fichier). Le fichier le plus important, config.cpp doit y etre placer a son tour
Lorsque tout ces fichier y sont vous etes enfin pret, utilisez votre compresseur PBO preferer
et compresser le en "nam_25.pbo". Placer le alors dans le repertoire ofp\addons. 

 
 
Repertoire Cutscene 
 
Les cutscene sont les sortes de video jouer lors du menu principal d'OFP.
Placer le repertoire "nam_25_anims/" dans le repertoire "ofp\Addons" et mettez
dans ce repertoire la mission "intro.nam_25". 
Vous devez inscrire tout les noms des cutscene dans
cutscenes[] = {“”}; dans le fichier config.cpp. 
Vous pouvez avoir plusieurs cutscene qui seront alors jouer aleatoirement. 
 
 
Config.cpp 
 
Voici un petit exemple d'un fichier config.cpp qui vous permettra d'obtenir rapidement une ile 
jouable dans OFP. Il y a bien plus de ligne de commande bien entendus que nous esperons pouvoir
detailler dans le futur. Mais ce petit exemple de fichier config.cpp est configurer pour une ile de 25km 
utilisant "SEB NAM Pack 2 environment sounds": 
 
class CfgPatches { 
 class nam_25 { 
  units[] = {}; 
  worlds[] = {nam_25}; 
  requiredVersion = 1.91; 
 }; 
}; 
 
class CfgWorldList { 
 class nam_25 { 
 }; 
}; 
 
class CfgEnvSounds {}; 
 
class CfgWorlds { 
 class DefaultWorld {}; 
 class Intro : DefaultWorld {}; 
 class nam_25 : Intro { 
  access = 3; 
  description = "Vietnam 25km"; 
  icon = "\nam_25\_nam_25.paa"; 
  worldName = "nam_25.wrp"; 
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  cutscenes[] = {"..\addons\nam_25_anims\intro"}; 
 
  // a-lone-wolf stuff 
  centerPosition[]={25600,25600,200}; //{6400,6400,0}; 
  landGrid=50; 
  class Grid 
  { 
   offsetX=0; 
   offsetY=0; 
   class Zoom1 
   { 
    zoomMax=0.200000; 
    format="XY"; 
    formatX="Aa"; 
    formatY="00"; 
    stepX=256; //128; 
    stepY=256; //128; 
   }; 
   class Zoom2 
   { 
    zoomMax=1e30; //1000000015047466219900000000000.000000; 
    format="XY"; 
    formatX="A"; 
    formatY="0"; 
    stepX=2560; //1280; 
    stepY=2560; //1280; 
   }; 
  }; 
 
  ilsPosition[] ={24871,12937,0}; // runway north end, touchdown spot? 
  ilsDirection[] ={0,0.08,1}; // no clue, north-south? 
 
  ilsTaxiIn[]= 
  { 
   24990,11975, // service path middle point 
   24990,12925, // point on runway to start there 
   24990,12954, // point on runway to start there 
   24940,12960, // point on runway to start there 
   // above is center of AB, then three points near the  
   // runway entrance. 
 
   24871,12950, // point on runway to start there 
   24871,12920, // align with runway 
   24871,12900, // align with runway 
   24871,11010, // align with runway 
   // and these are the runway pos and three points 
   // close to each other in the runway towards South. 
  }; 
  ilsTaxiOff[]= 
  { 
   24871,12937, //ilsPos, // touchdown point on runway 
   // this is the north end of runway. 
 
   24871,10945, // move to taxi-off point 
   24871,10913, // start turning 
 
   24990,10912, // move to taxi-path 
   24990,10945, // move to taxi-path 
   24990,11975, // move on service path to middle point 
  }; 
 
  class Sounds 
  { 
   sounds[]={}; 
  }; 
  class Animation 
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  { 
   vehicles[]={}; 
  }; 
 
  class Names 
  { 
   class Lawng_ngaw 
   { 
    name="Lawng-ngaw"; 
    position[]={22643.392578,16338.239258,67.500000}; 
   }; 
  }; 
 
  class EnvSounds: CfgEnvSounds 
  { 
   class Rain 
   { 
    name="$STR_DN_RAIN"; 
    sound[]={"\sebnam_ia_trang\sound\JungleRain.ogg",0.002,1}; 
    soundNight[]={"\sebnam_ia_trang\sound\JungleRain.ogg",0.002,1}; 
   }; 
   class Sea 
   { 
    name="$STR_DN_SEA"; 
    sound[]={"\sebnam_ia_trang\sound\JungleOcean.ogg",0.0008,1}; 
   
 soundNight[]={"\sebnam_ia_trang\sound\JungleOcean.ogg",0.0008,1}; 
   }; 
   class Meadows 
   { 
    name="$STR_DN_MEADOWS"; 
    sound[]={"\sebnam_ia_trang\sound\JungleAmbience.ogg",0.0006,1}; 
   
 soundNight[]={"\sebnam_ia_trang\sound\JungleNight.ogg",0.0006,1}; 
   }; 
   class Trees 
   { 
    name="$STR_DN_TREES"; 
    sound[]={"environmental\wave_break",0.000316,1}; 
    soundNight[]={"environmental\wave_break",0.000316,1}; 
   }; 
   class Hills 
   { 
    name="$STR_DN_HILLS"; 
    sound[]={"\sebnam_ia_trang\sound\JungleHill.ogg",0.0006,1}; 
   
 soundNight[]={"\sebnam_ia_trang\sound\JungleNight.ogg",0.0006,1}; 
   }; 
  }; 
 }; 
}; 
 
Bon d'accord j'ai mentis, ce n'est pas si petit mais c'est un debut. Noter ce que nous avons indiquer
dans worldName = "nam_25.wrp";  

Ce fichier n'est pas dans "nam_25.pbo" mais dans "ofp\Worlds" ce qui permet de charger la map
plus rapidement lorsque vous desirez la testez. Vous ne voudriez pas a avoir a faire un fichier pbo
chaque fois que vous voulez voir si votre ile fonctionne convenablement.  
 
OBien sure lorsque votre ile sera terminer il sera plus pratique de l'integrer au fichier 
"nam_25.pbo" et la ligne de commande deviendra alors:  
worldName = "\nam_25\nam_25.wrp"; n'oublier pas de mettre le fichier "nam_25.wrp" dans le repertoire 
"nam_25\" du repertoire principale du fichier "nam_25.pbo" ce qui est normal par rapport a la ligne
de commande.  
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DefaultWorld 
 
Au lieu d'utiliser "DefaultWorld {}"; dans la config de votre ile, nous vous suggerons d'utiliser 
une config specifique, comme dans cette exemple: 
 
class CfgWorldList  
{  
    class WrpToolWorld {};  
};  
  
class CfgWorlds  
{  
    class WrpToolWorld  
    {  
      .  
      .  
     all world parameters  
      .  
    };  
}; 
 
 
Coordonnées géographique 
 
OFP peut calculer des coordonnées géographique (latitude et longitude) qui permettent 
de definir le mouvement des etoiles, ainsi que l'affichage du soleil. l'entrée dans le fichier config.cpp 
est la suivante: 
 

latitude= x 
longitude= z 

 
Celles ci doivent etre placer juste en dessous de "CenterPosition[]=" dans le fichier config.cpp. 
vLes valeurs X et Y indique la positions de votre iles sur la planete. 
(Ranges: -90 (Pole arctique) < x > +90 (Pole antarctique) and -180 < z > +180). 
 

Ceci permet de donner du realisme au jeu puisque grace a ces données les etoiles, le soleil 
ce deplacent comme dans notre monde et celon les meme normes saisonniere. 
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IMAGETTE DE L'ILE
 
Pour avoir une image reduite de votre ile dans l'editeur de mission ou en multijoueur 
vous devez creer une image paa comme configuré dans le fichier config.cpp . 
 

 
 
TCette imagette et à une resolution normale qui peut etre 64X64, 128X128 ou au
maximum à 256x256. Vous ne pouvez integrer beaucoup de details à cette image,
elle n'est la que pour donnée une vue d'ensemble de votre ile.
island and that is enough for it. Pour commencer vous devez capturer une vue d'ensemble
de votre map, Wrptool ne permet pas de le faire automatiquement à l'heure actuel mais nous
y reflechissons. 
WNous vous conseillons de zoomer au plu loin de la map sous wrptool et de prendre un 
"imprim écran" et d'y colle l'image dans votre editeur de dessin préféré.
 
Ici nous vous expliquons comment faire les operations exiger sous PaintShopPro. 
D'autre utilitaire ne marche pas de la meme façon et nous ne pouvons pas tous les expliquer. 
 
 
Redimensionné l'image 
 
Enregistrer l'image au format TGA. Assurez vous que vous etes dans une resolution 
convenable, ici nous utilisons 256x256. Utilisez SHIFT-S pour aller dans la fenetre de redimension.  
Dans "Pixel Size" mettez 256 pour "width" et "height", n'oublier pas de deselectionné 
"Resize all layers" et "maintain aspect ratio". Cliquez OK et votre image et maintenant a une  
resolution de 256x256.  
 
 
Alpha Channel 
 
Ouvrir le TGA, utiliser CTRL-A pour selectionner tout. Aller dans le menu "Selections -> Save 
To Alpha Channel". La fenetre de sauvegarde d'alpha channel s'ouvre, cliquez sur OK et 
il vous demande le nom du nouveau cannal (“New Channel”), cliquer aussi OK. Vous avez 
alors creer un alpha channel dans votre image. 
 
Appuyez sur F12 pour sauvegarder, selectionner dans "Save As Type" le type d'image 
"Truevision TARGA". Cliquez sur "Options" et selectionnez "24 bits", "Uncompressed". 
Cliquez sur "save" et c'est bon, l'image et sauver en format TGA pour OFP. 
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Texview 
 
Nous utilisons ensuite "Texview" de "BIS" pour convertir le fomat "tga" en format "paa". Ouvrir 
"Texview", selectionner "Open" et ouvrez le fichier "TGA" sauver sous PaintShopPro. Ensuite 
selectionner "File -> Save As" et de ce menu, indiquez le nom sous lequel vous desirez sauvegarder, 
assurez vous alors que le fichier et bien en .paa pour pouvoir etre lus par OFP. 
 
Vous avez alors votre fichier .paa que vous devez nommer comme celui configurer dans 
le fichier config.cpp. Placez le fichier paa dans le repertoire "addon" de votre ile et il 
apparaitra alors dans OFP, si non… nous ne pouvons pas vous aidez plus alors verifiez bien d'avoir
tout fait comme indiquer. 
 

 
 
Voici notre liste. 
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APERCUS DE VOTRE ILE 
 
Dans le cas ou vous desirez avoir un apercus de votre ile sous OFP vous devez quitter
tout programme ayant rapport avec la creation de l'ile (wrptool, compresseur Pbo etc..), 
puis deplacer la carte au complet dans le repertoire Addons d'OFP et demarrez OFP.
 
Vous avez une maniere plus rapide d'avoir l'apercus. Premierement construisez votre fichier
config.cpp de sorte a avoir votre fichier wrp dans le repertoire "ofp\Worlds" et pas 
dans un addon pbo. Vous devez mettre vos p3d’s & textures dans le repertoire 
"Addons" normal pour que OFP puisse les lire.  
 
Savegarder le fichier wrp dans le repertoire "worlds", mais ne quittez pas Wrptool pour autant,
laissez le en marche. Demarrez OFP, et aller dans l'editeur de mission ou si vous avez deja
configurez votre mission demarrez l'apercus de votre ile. 
Lorsque vous desirez editez votre ile, faites "ALT+TAB" sous OFP (ou executer le en mode fenetré)
et dans WrpTool faites vos modifications. 
 
Maintenant que vous avez fait vos modifs, sauvegarder votre wrp dans "ofp\Worlds" 
retourner dans OFP charger une ile quelconque et recharger alors votre map pour voir
les nouvelles modifications. 

 
Si vous desirez aller plus vite encore, Exporter juste une petite partie de votre ile 
(souvenez vous du 32x32, 64x64) ainsi le chargement sera beaucoup plus rapide. 
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WILBUR : TUTORIAL POUR LA CREATION D'ILE 
 
Dans ce tutorial nous abordons la creation d'un terrain de bas avec Wilbur, 
nous avions deja parler de ce qu'on pouvait faire avec ce logiciel... Maintenant installer
on va pouvoir l'utiliser.
 
Dans cet exemple nous fabriquerons un terrain de 25.6km x 25.6km, ce qui 
correspond sur la grille à des cellules de 512x512. 
 
 
Comment utiliser Wilbur 
 
Demmarrez Wilbur, et cliquez sur “New”en haut a gauche. 
Cette fenetre apparait et demande la taille du terrain.  
 

 
 
Comme indiquer vous inserez 512 pixels pour la largeur et la hauteur, ce qui nous 
fait un terrain de 25km (512 x 512 cellules). Cliquez sur "next" et une nouvelle 
fenetre apparait (Surface Edges) qui vous demande des valeurs, laisser comme elles sont 
et cliquez sur "Finish". 
 
Maintenant un fond bleu apparait que l'on considere comme le niveau de l'ocean (0 metres). 
Ensuite nous choisissons notre methode de dessin, selectionnez "Raise" et "50x50" comme 
indiquer dans l'image qui suit. Wilbur permet l'importation de terrain creer avec TerraGen 
mais dans notre exemple nous peindrons l'ile nous meme. 
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Double cliquez alors sur l'icone "Paint" sur la barre superieur pour configurer les brosses. 
wIci nous avons choisis 5 dans la case "value" ce qui signifie que lorsque vous cliquer
sur une zone celle ci augmente de 5 metres et lorsque vous faites glisser la souris tout 
en cliquant, la zone parcourue augmente de 5 metres. 
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WUne fois configurer nous somme prets a peindre notre terrain dans la zone bleu de 
Wilbur. Dessiner un terrain qui vous semble appreciable. Plus vous cliquerez ou vous 
bougerez la souris tout en maintenant le clique sur une meme zone plus les couleurs virerons 
vers des couleurs chaude. Cela indique le degré d'elevation du terrain; le plus haut dans Wilbur 
est representer par la couleur blanche.  
 
Apres votre premier gribouillage, vous pouvez utiliser "Relight" pour eclaircir la map
et mieu faire apparaitre les reliefs. Le bouton "Relight" est indiquer ici :  
 

 
 
Supposons que vous ayez paint le terrain que vous vouliez, dans notre exemple 
le terrain a deja subit l'option "relight".  
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Bien. maintenant regardons l'elevation de plus pres, celle ci sont indiquer dans le coin inferieur 
droit de Wilbur et les coordonnées affiche l'elevation actuelle (et les coordonnées X, Y) 
situer sous le pointeur de la souris. 
 

 
 
YVous pouvez remarquer que plus le terrain est haut plus les couleurs sont chaudes allant 
au blanc pour la plus haute elevation. Dans Ofp, toute elevation en dessous de 5 metre 
sera submergé par les marées. Si vous ne voulez pas vous retrouvez avec un lac ou
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une riviere assurer vous que le niveau est au dessus de 6 metres. 
Assurez vous de ne pas depasser 1000 metre ou faites une pente douce pour eviter  
que lorsqu'un soldat tombe il ne se tue pas (sauf si c'est ce que vous desirez) 

 
Si vous desirez faire une riviere traversable comme dans "SEB NAM Pack’s Ia Drang island",  
utilisez une elevation de 1 metre pour faire un morceau de pont de terre enfoui dans l'eau
mais traversable par les soldats et les vehicules.
 
Quand vous estimez avoir terminer nous vous conseillons d'utiliser l'outil "Blur" pour  
applanir le terrain. On peut remarquer que sur des iles plus grandes que notre exemple
les bord mal finis font lagger OFP durant le jeu ou meme dans l'editeur de mission.
Mission Editor. Ici vous pouvez voir un morceau de terrain arrondis et aplanis par cet outil :
 

 

 
 
Utilisez le autant de fois que necessaire pour faire en sorte que ca ne laggue 
pas dans OFP. 
 
 
Exporter les informations 
 
Pour exporter votre terrain aller dans "File -> Save As", et mettez dans  
"Save As Type" : "Lon/Lat Text Mesh (*.txt)" . Quand vous avez choisis un nom de fichier
et que vous avez appuyez sur "Save" une fenetre comme celle ci apparait : 
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Vous devez cliquez sur "Set to Pixel"; editer "Decimal Places" à 0 pour le rendre 
compatible avec WrpTool. Vous pouvez aussi faire des modification au niveau de 
l'elevation, la valeur Z dans la boite "Maximum" vous permet d'ajuster si vous trouvez que 
votre terrain et trop ou pas asser elevé. 
 
Une fois tout terminer nous vous suggerons de sauvegarde de nouveau votre fichier 
mais cette fois en "BMP Texture (*.bmp)". 
Celui ci ne sera pas necessaire a wrptool mais il vous permettra d'avoir une reference
de votre terrain. 
Ici nous nous heurtons a un defaut stupide de Wilbur, Vous ne pouvez pas sauver votre terrain.
; enfin du moins pas pour un terrain reutilisable sous wilbur.
Quand vous charger un terrain sous wilbur celui ci reaparrait avec un niveau remis a zero 
ce qui le rend donc ininterressant. 
 
 
Importer un fichier Wilbur dans WrpTool 
 

C'est tres simple. Lancer Wrptool, creer une nouvelle carte avec les dimension du terrain
creer sous wilbur (dans notre exemple 512) puis vous voila pret a importer votre tout joli
terrain. 
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Choisissez "File -> Import Wilbur" et rechercher votre fichier Wilbur, 
Wrptool affiche votre terrain et crée les elevations. Vous devriez zoomer ou dezoomer
pour rafraichir la vue, et vous pourrez voire ensuite votre map importer comme  
dans notre exemple ci dessous. 
 

 
 
Et voila, vous pouvez desormait travailler avec votre terrain perso sous
wrptool. 
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WRPTOOL AU TUTORIAL D'OFP 
 
Ici nous vous expliquons comment faire pour reussir a jouer normalement a votre 
carte sous Ofp. Dans notre exemple nous appelerons notre ile 
“nam_25” et toutes les references seront a ce nom. 
 
 
Example de Configurations 
 
Avec WrpTool vous avez obtenus un repertoire appeller "Example_Configs", dedans 
vous pouvez trouver trois exemple pour configurer et tester votre ile. 
Ceux ci inclus la config pour des iles de 12km, 25km et 51km, meme de petites 
animations sont la pour les cutscenes. 
 
Dans le repertoire OFP/ vous pouvez trouvez deux repertoire, Addons/ et Worlds/. Dans 
le repertoire "Addons" vous trouvez le menu principal, le repertoire "cutscene anims" et 
les fichier pbo pour chaque ile qui contient un "config.cpp" etc.....
Worlds/ contient trois iles au format .wrp. 
 

 Dans "Example_Configs" vous trouvez trois repertoire nommés "wrptool_12km", 
"wrptool_25km" et "wrptool_51km" contenant un fichier .paa (pour l'imagettee) 
et le fichier "config.cpp".
Ces trois repertoires sont liés au fichier pbo contenus dans le repertoire OFP/Addons/ 
; Il n'ont pas ete compresser.  
 
Format Wrp 
 
Le format sauvegarder par wrptool est: "4WVR". OFP lis ce format sans probleme et vous 
vous pouvez l'utiliser durant la phase de creation de l'ile. Cependant lorsque vous desirez
partager votre ile avec les autres joueurs d'Ofp, vous avez interet a binarizer celle ci en format
"OPRW v3" car celui ci prend largement moins de place. 
 
 
Config.cpp  
 
"config.cpp" se presente ainsi: 
 
class CfgPatches { 
 class nam_25 { 
  units[] = {}; 
  worlds[] = {nam_25}; 
 }; 
}; 
 
class CfgWorlds { 
 class DefaultWorld {}; 
 class Intro : DefaultWorld {}; 
 class nam_25 : Intro { 
  description = "test 12km"; 
  icon = "\nam_25\_nam_25.paa"; 
  worldName = "nam_25.wrp"; 
  cutscenes[] = {"..\addons\nam_25_anims\intro"}; 
 }; 
}; 
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class CfgWorldList { 
 class nam_25 {}; 
}; 

 
Votre ile “nam_25.wrp” serait requis dans le repertoire "ofp\Worlds" au lieu de ca il
se trouve dans le fichier .pbo. Le fichier "config.cpp" montré ici, est le plus petit connus 
à ce jours. Si vous en supprimer une partie votre ile ne fonctionnera tres certainement pas 
sous OFP. 
 
Ce fichier "config.cpp" marche pour toutes les tailles d'ile… 
 
 
Addon pbo 
 
L'addon pbo est requis pour creer sont propre repertoire pour l'ile, le repertoire 
se nomme “nam_25”. Dans ce repertoire vous devez avoir "config.cpp" et l'icone de l'ile 
en fichier .paa.  
 
Quand tout est pret, utilisez un compresseur pbo pour compresser tout ca en l'appelant 
comme le nom de son repertoire, ici "nam_25.pbo" sera son nom. Ce fichier pbo doit etre 
placer dans le repertoire "ofp\Addons". 
 
 
Animation de l'ile: Cutscene 
 
Si vous desirez creer une animation pour le menu principal vous devez creer le 
repertoire "nam_25_anims". Ce repertoire doit contenir "intro.nam_25" pour jouer 
le cutscene desirer. Si vous ne desirez pas construire tout de suite votre cutscene 
tprenez en un existant dans le repertoire "Example_configs" et renommer le 
pour que celui ci corresponde a votre map.

 
Demarrez Ofp et vous devriez voir l'ile en fond. Si ce n'est pas le cas 
c'est que quelque chose a mal tourné ☺ 
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INFO CONTACT 
 

L'equipe de devellopement est encourage tout ceux qui veulent creer des maps pour 
OFP. Nous serions heureux de recevoir des utilisateurs de WrpTool, pour tout message, 
ou question a nous posés.  
 
Si vous desirez rapporter un bug, une erreur ou bien deposer un commentaire, un 
conseille etc... Visitez notre page web WrpTool Project ou vous trouverez aussi les 
dernieres infos. 
 
Forum 
 
N'hesiter pas a venir sur le forum area. Vous y trouverez les dernieres astuces 
ou objets creer par d'autre utilisateurs ou peut etre meme des config pour vos 
maps etc.  
 
Tout les derniers bugs peuvent aussi y etre trouver. 
 
 
IRC channel 
 
Nous avons aussi un cannal IRC (internet relay chat) se trouvant sur 
quakenet au nom de "#wrptool" – Venez voir et discuter avec nous. 
 
 
Email Address 
 
Vous pouvez nous atteindre par mail, qui en soit et la forme la plus lente de contacter
l'equipe de developpement. Notre adresse est: flashpoint@nekromantix.com . 
 
 
Rapport de Bug 
 
Une page reserver au bug existe pour partager les bugs trouver dans le logiciel. 
Cette page ne vous oblige pas a nous transmettre quelques informations que ce soit, 
mais vous pouvez indiquer si vous le souhaiter votre email ou nom. 
Cette page peut etre trouver ici .
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Dschulle, Rom et Snake Man ou tout groupe affilié ne prend aucune  
responsabilité si jamais un degat est causer directement ou indirectement 
a votre personne, votre ordinateur ou logiciel par WrpTool. Vous avez  
été prévenus! 
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